Project

General

Profile

Emulator Issues #3247

save states wont work with metroid other m

Added by vasishath about 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Start metroid other m.
2. Create a save state.
3. Load that state.
What is the expected output? What do you see instead?
The state should load.
It doesnt load. Either shows a blank screen or still image with game hanged. Occurs for both , cutscenes as well as gameplay.
Dolphin version with the problem?
R6xxx x64
Other Dolphin version without the
problem?
No version to my knowledge.
32-bit or 64-bit and any other build parameters?
64 bit.
OS version and versions of tools/libraries used?
Windows 7 x64
Please provide any additional information below.
The savestates are needed for the game for the infinite tutorial and elevator bug as u need to change audio to openal. Then switching back to dsound is necessary as the gameplay goes crappy. If they dont work , we have 2 watch the cutscenes once again and thats really boring.... :(


Related issues

Is duplicate of Emulator - Emulator Issues #2484: Savestates do not workFixed

History

#1 Updated by skidau about 10 years ago

  • Status changed from New to Duplicate

I have investigated this issue and it is to do with the save state not capturing the status of the wiimote. We'll track this from issue 2484.

#2 Updated by keithvsmith1977 about 10 years ago

I've noticed if you try to load another state during the "black scene", it'll show the screen as loaded from the state, but frozen. I've managed to get it to load a save state periodically by making sure the WiiMote is checked off as connected under the "Tools" Menu when saving the state & reloading the state multiple times till it loads correctly.

#3 Updated by gabrielmorano almost 10 years ago

This issue is not only for Metroid Other M, it's a general games issue, it happens A LOT on the metroid prime games, on dead rising it's imposible to use it as it will surelly end up doing this and there aree a few more games
save state it's still unsafe (at least it does not crash the emulator anymore, but time to time it freezes it)

this goes up to r6665

Also available in: Atom PDF