Project

General

Profile

Emulator Issues #3381

[Kirby Epic Yarn] Major speed issues

Added by wespipes69 almost 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Launch the game and enter a level (poor speed is most consistently on the stage 1 boss - Karuan)

What is the expected output? What do you see instead?
At random times, speed will dip down to about 50% and sometimes just stay there depending on the scene. The entire stage 1 boss fight runs at a steady 60%. Seems like the further you get into the game the slower the levels run.

Dolphin version with the problem? Other Dolphin version without the
problem?
Current revs - r6298

32-bit or 64-bit and any other build parameters?
x64

OS version and versions of tools/libraries used?
Win7

Please provide any additional information below.
--Behavior is confirmed on the forums.
--Happens with either "Progression Display" on or off - JIT or JITIL. Cannot find any setting that affects these slowdowns.
--This game should not be that taxing. That and I have a fast computer that can run SMG2 full speed (to give you some perspective).

History

#1 Updated by wespipes69 almost 10 years ago

--Also, the game ran fullspeed in r4775. But the game is even more unstable in that version (unplayable).

#2 Updated by alexey1235 almost 10 years ago

r4775 is not exit on this sutuation!
Maube in next revs developers fix kirby EY

#3 Updated by skidau almost 10 years ago

Please test out r6304. If that does not fix it, the problem is probably in the texture cache (r6288).

#4 Updated by wespipes69 almost 10 years ago

Just tried it but it's about the same. It looks faster...I'll say that on average during the fight i'm getting about 5 more FPS (so averaging about 60-70% "speed" now). That's with or w/o XFB - does the game even use this?

#5 Updated by wespipes69 almost 10 years ago

FYI just tried r6211 and the slowdowns are almost identical. So this has been around for ahwile (not caused by r6288).

#6 Updated by wespipes69 almost 10 years ago

As of r6308, the issue is still present - first boss is still about 65% speed.It's better than where it was 50 revs ago, so we are making everything run a lot better. But something is still just holding this particular game back for some reason.

#7 Updated by Luke.Hernandez almost 10 years ago

I got 50fps in the first boss, the Dragon :) in both plugins Dx9 and Dx11

#8 Updated by wespipes69 almost 10 years ago

PAL or NTSC? Steady 50? You'd be the only one. What settings other than default are you using? What's your rig? Just because you have an insane machine and can play this game properly doesn't mean that this simple game should be so slow for the majority of users. There's obviously a dolphin issue here.

#9 Updated by Luke.Hernandez almost 10 years ago

Here is some proof, besides the default configuration I just use Dx11 enable safe texture cache, nothing more, ahh, Also I play in full screen at 1024 * 768

http://i51.tinypic.com/11szifo.jpg

My PC:

Cpu : i3 at 3.8 GHz
Ati HD 3650
2Gb RAM

#10 Updated by Luke.Hernandez almost 10 years ago

Here it is the second boss, almost full speed all the time (50-60fps)

http://i51.tinypic.com/29ncpsk.jpg

#11 Updated by skidau almost 10 years ago

  • Status changed from New to Invalid

Proof provided that the slowdown does not occur for everybody.

#12 Updated by wespipes69 almost 10 years ago

Hey Skid, can you please reopen? This is a valid issue. Even one of this guy's screenshots shows the game running at about 80% (50 fps out of 60 - it's ntsc).

Take a look at the official thread on the forums - it's full of people experiencing minor to severe speed issues. It's not all the time, but there are slowdowns all over the place (some pretty bad). http://forums.dolphin-emu.com/thread-12607-page-5.html

Also, the fact that r4775 does not exhibit these speed issues proves to me that some thing has happened in Dolphin to cause this game to have irratic speed behavior. There's something going on here and I can't find any setting that affects this issue.

#13 Updated by skidau almost 10 years ago

This issue is a bit vague and it's looking like a hyrule field scenario. Maybe if you can find the exact revision that causes the slowdown we can work with it. As it currently stands, we would not know where to start debugging. r4775 might be faster but it is not as compatible.

#14 Updated by daws72 almost 10 years ago

At skidau : if you want please check issue 2811. The sudden speed reduction is very noticeable in that situation. The table tennis game in Wii sport resort, don't change the visuals so much to guess a problem on the graphics/texture etc. It looks more as a bottle neck on the CPU emulation.

Also available in: Atom PDF