Project

General

Profile

Emulator Issues #3431

Super Mario Sunshine - Issue 3 -> EFB scaled copy bug REPOST

Added by WMRPoker about 11 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have to repost the issues, as it seems that j4ck.fr0st has blindclosed 3408, none of the bugs were fixed though, not even the red flahsing glitch!
I will now split the 3 defects of issue 3408 into 3 separate reports.

What steps will reproduce the problem?
1. Start Dolphin, choosing any graphics plugin
2. Start Super Mario Sunshine

What is the expected output? What do you see instead?
Having EFB scaled copy enabled in the DX9 plugin makes the goo look edged... (see screens)

Comment from gnick79 in the old issue post:
" I can confirm (here r6314) that exists an issue in SMS when "EFB scaled copy" setting is turned on.
Now... besides the edges...
... this option constrains to set "Internal Resolution" (from user action) to Auto-integral, fractional nope... otherwise paints go away :D LoL.
When "EFB scaled copy" is on, again SSAA x9 can corrupt paints... even if internal resolution is set to integral. "

Dolphin version with the problem? Other Dolphin version without the
problem?
Tested with the latest build (6320).

32-bit or 64-bit and any other build parameters?
I only use the 64-bit version of Dolphin.

OS version and versions of tools/libraries used?
I run Windows 7 64-bit.

Please provide any additional information below.
PC specs:
Intel Core 2 Quad Q6600 2,4 Ghz
ATI Radeon HD5770, 1GB
4 GB RAM @ 800 Mhz
Win 7 64-bit

History

#1 Updated by WMRPoker about 11 years ago

I found out, that SSAA affects this glitch. Having SSAA turned off makes the goo look good (besides that it aint anti-aliased no more of course).

#2 Updated by skidau about 11 years ago

  • Category set to gfx

#3 Updated by gnick79 about 11 years ago

  • Status changed from New to Invalid

This is an unfixable issue due to upscaling textures resolution.
Depend what internal resolution you have, you need to turn off EFB scaled copy hack.
Turn off bi/trilinear filter also.

Also available in: Atom PDF