Project

General

Profile

Emulator Issues #3476

Disappearing/Odd polygons in Sonic Heroes (DX9 Only)

Added by knuckles500 over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Boot up Dolphin (r6331 and up is confirmed with this problem)
2. Launch Sonic Heroes (any version)
3. Get to the Team Selection screen, it all goes downhill from here

What is the expected output? What do you see instead?
I expected it to look like this:

(all of these captured on r6373 using the DirectX11 plugin)
http://imgur.com/k3edq.png
http://imgur.com/wSRQF.png (gameplay, that shadow graphic isn't supposed to be there by the way)

But instead, I get this with the DX9 plugin:
http://imgur.com/t07pU.png
http://imgur.com/X7WBr.png

Dolphin version with the problem? Other Dolphin version without the
problem?
R6331 was tested, but of course, it might've been happening well before this.

32-bit or 64-bit and any other build parameters?
64bit build from Dolphin-Emulator.com

OS version and versions of tools/libraries used?
Windows 7 x64

Please provide any additional information below.
I need to go by revision to find out what change caused this, but I do remember this working the way it should not too long a go. I've tested the DX9 with all the settings, and nothing fixes the problem. However, the DX11 displays the game as it should (nix the shadow problem).

Just wanted to let you know that something that was changed for the DX9 and might be making some other games worse like this. Not sure which revision did it yet, though....

History

#1 Updated by skidau over 9 years ago

  • Status changed from New to Invalid

Projection hack setting was enabled. Disabling fixed the issue.

#2 Updated by knuckles500 over 9 years ago

Just for future reference, this is the problem - which needs to be fixed:

ah
i see the problem
dolphin doesn't have a default choice for projection hacks if theres a game .ini that doesnt state it to have one or not
so if the game's ini didn't state a projection hack, dolphin would only list a blank on the drop down list in game properties
and that blank spot will be whatever last game had a projection hack selected
so in this case since sonic colors had the twlight princess project hack enabled, the blank spot for sonic heroes's gameconfig window had the twlight princess hack enabled
haha
so to fix it - you should make dolphin assume the default projection hack selection when the game ini doesnt state one to be "none" by default

So basically if a game has nothing (a blank) selected under Projection Hacks under the Game Properties' GameConfig window, it'll use the one that you selected last for a game (in this case for me, I selected the Twilight Princess Bloom hack for another game and Sonic Heroes got confused when it didn't have a valid choice for Projection Hacks enabled and used the one I selected last for the last game). To fix this, just make Dolphin assume "None" for projection hacks unless the Game ini states otherwise. If it doesn't, then have the game use "None" by default.

Hope this makes sense...can't think too clearly at the moment...

Also available in: Atom PDF