Project

General

Profile

Emulator Issues #3522

Smg water have some issue with efb scale, 4xsaa and 16x filtering

Added by giaga7 over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Hi all, from about ever i noticed like in issue 3435 that water change, it become more transparent than normal, with varoius settings that influence the video definition so like SSAA, anisotropic filter, efb scale 2x,3x... the only options that make it right is native sith all other disabled and with native mipmaps enabled, look at screenshots:

4xSSAA and 3x scale:

2x scale only (still a little bit too transparent):
http://img232.imageshack.us/img232/9673/correct1.png

native mm disabled:
http://img844.imageshack.us/img844/4419/4xssaa16xafmmdisabled.png

16xfilter only:
http://img232.imageshack.us/img232/808/16xfilter.png

Native only(correct):
http://img683.imageshack.us/img683/746/rmgp0111.png

So, there's anyway to correct this and make it show correctly in every scaling or with filters?
Like in issue 3435 I tried r6314 but also r6381, in dx9.

History

#1 Updated by giaga7 over 9 years ago

Sorry I forgotten 4xSSAA and 3x scale image:
http://img600.imageshack.us/img600/6020/4xssaa.png

#2 Updated by frango0010 over 9 years ago

Well, those bugs are caused by the forced filters, and not the EFB Scale..
The only reason I see for the water becoming a little more transparent as the EFB Scale goes up, is the lack of pixelation on higher scales.. Except for that, everything is perfect on the scale only screenshot.

#3 Updated by giaga7 over 9 years ago

So it is right? Or it can be fixed and the water can remain as in native?:)

#4 Updated by skidau over 9 years ago

  • Status changed from New to Invalid

Closing based on frango0010's comment.

Also available in: Atom PDF