Project

General

Profile

Emulator Issues #3539

Zelda WW Flicker

Added by NaturalViolence over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

Certain textures in wind waker such as waves flicker. Example: http://www.youtube.com/watch?v=6JMTJfbsOd8

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):

5896 or higher.

(optional) Dolphin version that does not have the problem:

5895 or earlier

Please provide any additional information below.

I didn't think I would need to post an issue for this on googlecode. I told NeoBrain about this on irc and reminded him MANY times. I showed him exactly what code caused it, it's been a month now and still nothing has been done. The issue was caused by changes made to the culling of z textures commited in 5896, it has been present ever since. Since that change does not fix anything, only improves performance slightly, and probably broke some textures in other games as well I don't see why we should hold on to it.

History

#1 Updated by Theevillightbulb over 9 years ago

This looks to me like it's an issue with shadows not "Waves"

#2 Updated by NaturalViolence over 9 years ago

No it isn't. It's caused by z textures being culled to early, it was caused by r5896. Shadows might also be affected since they probably rely on z textures as well. Stand on the porch outside grandma's house on outset island and look at the ocean from an angle and you will see the waves flickering.

#3 Updated by frango0010 over 9 years ago

Wasn't precision > speed? I wonder why this issue, which is easy to fix, since it's been already tracked down to a specific revision, hasn't been fixed yet...

#5 Updated by NaturalViolence over 9 years ago

Out of curiosity I went ahead and tested my other games for this issue. So far I have only found 1 other instance of this issue. In Metroid Prime the lava in magmoor caverns flickers at certain camera angles the same way. Sure enough the flicker in there in 5896 but not in 5895 so it is definitely the same issue. So now we know it affects multiple games on top of everything else.

#6 Updated by NaturalViolence over 9 years ago

This issue can be closed now. Fixed in 6517.

#7 Updated by NeoBrainX over 9 years ago

  • Status changed from New to Fixed

#8 Updated by NeoBrainX over 9 years ago

  • Status changed from Fixed to Accepted

Aaaaand... reopening after r6592 reverted the fixes...

#9 Updated by NaturalViolence over 9 years ago

This issue can be closed again thanks to 6622, and hopefully for the last time.

#10 Updated by NeoBrainX over 9 years ago

  • Status changed from Accepted to Fixed

#11 Updated by Metzelmaennchen over 9 years ago

Sorry to say... but the bug appears again. At least r6686 shows this.

#12 Updated by NeoBrainX over 9 years ago

Yeah and there are some glitches in Mario Kart Wii again as well... seems like pixel depth still isn't quite perfect.

#13 Updated by NeoBrainX over 9 years ago

  • Status changed from Fixed to Accepted

#14 Updated by NaturalViolence over 9 years ago

This issue can be closed.

#15 Updated by NeoBrainX over 9 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF