Project

General

Profile

Emulator Issues #3577

widescreen hack objects appear off screen at curtain angles

Added by Linkinworm over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
objects will dissapear off screen with widescreen hack enabled when at the edge of the screen

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
all that i know of

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:
32-bit win 7

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Please provide any additional information below.

while not game breaking would be nice to be able to have it enabled as it corrects aspect ratio for games forces in widescreen


Related issues

Is duplicate of Emulator - Emulator Issues #7128: Widescreen Hack Currently Performs PoorlyAccepted

History

#1 Updated by MofoMan2000 over 10 years ago

Items disappearing when on the edge of the screen with widescreen hack cannot be fixed. This is due to the game itself thinking the object is no longer needed and isn't rendered anymore, at all. For widescreen hack to work properly, it depends on games being sloppy about this.

I'm more concerned about issues with widescreen hack that can be fixed. Ever try playing Super Mario Sunshine with the WSH? Heat blur effects are completely fucked, and an easy fix would be to restrict the effect into a 4:3 ratio.

#2 Updated by NeoBrainX over 10 years ago

  • Status changed from New to Invalid

What he said. Widescreen hack will cause problems which aren't fixable.

#3 Updated by MayImilae about 7 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF