Project

General

Profile

Emulator Issues #3582

True Crime: SoLA does not boot in JIT or JITIL

Added by MofoMan2000 almost 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
As soon as True Crime: Streets of LA is booted up (after the IPL runs if desired) it instantly crashes. If panic handlers are enabled you get these messages:
"DSI exception in lmw"
"DSI exception in stmw"
"ERROR: Trying to compile at 0. LR=802b4548"

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
This occurs in r6486

(optional) Dolphin version that does not have the problem:
I don't know when this started happening, but my bet is this game has been unplayable for quite some time. I tried with r6024 and it wouldn't run (but it wouldn't show the errors either). If it helps, I remember this game was very playable back in maybe r2200, with the TLB hack and disabling panic handlers.

Operating system and version: Windows XP
32-bit or 64-bit: x86

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
GTLE52

Was the ISO a plain dump from disc, compressed and/or scrubbed?
Raw ISO, ripped from my own disk.

Please provide any additional information below.
Sorry I couldn't be more precise on when the game used to work, my build archives only go back as far as r3085 and I can't even get that revision to boot anything anymore.

History

#1 Updated by MofoMan2000 almost 10 years ago

Exceptioninfo.txt generated from one of these crashes:

Unhandled Exception
Code: 0xC0000005
Call stack info:
Dolphin!0x00000000 : ?

#2 Updated by MofoMan2000 almost 10 years ago

Since r4695, only the last error is appearing ("ERROR: Trying to compile at 0. LR=802b4548") but it's still broken.

#3 Updated by tommyhl2.SS almost 10 years ago

Using the MMU speed hack should solve this.

#4 Updated by NeoBrainX almost 10 years ago

  • Status changed from New to Invalid

What he said.

#5 Updated by MofoMan2000 almost 10 years ago

Hmm, true. I made an issue at the cheats database SVN for it.

#6 Updated by N.Elworthy over 9 years ago

mine does this as well,, i have super mario sunshine and my game loads until the Dolby surround sound logo comes up then says ERROR : trying to compile at 0. LR = 802a6be8 what do i do the file is .gcm and its really frustrating

Also available in: Atom PDF