Project

General

Profile

Emulator Issues #3583

Everything runs too goddamn fast after loading GCN IPL

Added by MofoMan2000 over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
In many aspects the emulator seems to be running at two times normal speed. I first noticed this a while back, when I looked at the RTC in the GCN IPL. It is showing almost the correct time (it's a couple minutes slow), but it seems to be counting two seconds for every real second. At the time I didn't think much of it.

Then I tried playing Super Smash Bros. Melee (either selecting it from the menu or after the little cube rolls around), and it was the same story… The match timer ran at 2x speed, and so did the entire game. But the FPS and VPS counters both showed 60FPS and it says it's going only 100%.

I tried everything I could think of. Framelimit set to "auto", framelimit set to "60 (FPS and VPS)" and I even tried audio throttle in the DSP plugin. The only workaround I found was setting framelimit to 30.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
r6486

(optional) Dolphin version that does not have the problem:
Well I got sick of testing but this has been happening since at least r6353 (probably much longer).

Operating system and version: Windows XP
32-bit or 64-bit: x86

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
Any, but for SSBM it was GALE01

Was the ISO a plain dump from disc, compressed and/or scrubbed?
It's a raw ISO dumped from my disk.

Please provide any additional information below.
Dualcore, singlecore, idle skipping, none of it matters.


Related issues

Has duplicate Emulator - Emulator Issues #5403: GC IPL Paper Mario runs too quickly (possible CPU detection issue?)Duplicate

History

#2 Updated by MofoMan2000 over 9 years ago

Come to think of it, I think this has always been a problem since day one. I remember people noticed speedups when booting from IPL or any BIOS really (GCOS was specifically mentioned) back when speed was very hard to come by, in the 1.02 or 1.03 versions before the source was open. I'm surprised nobody has opened an issue about this yet. But I could be completely wrong.

#3 Updated by MofoMan2000 about 9 years ago

Here's the installer for Dolphin 1.03, for anyone willing to test out this issue on it, or for anyone just curious to see how far the project has come. The filename lies, it isn't the installer for 1.0.3.2, it's 1.03.

http://www.mediafire.com/?646t7xrh2vnrwxy

#4 Updated by skidau about 8 years ago

issue 5403 has been merged into this issue.

#5 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#6 Updated by skidau about 7 years ago

  • Status changed from New to Fixed

Enabling Accurate VBeam Emulation fixes this issue in the latest versions (3.5-1224 tested).

Also available in: Atom PDF