Project

General

Profile

Emulator Issues #3586

Wii Sports Resort - Return from Instructional Videos hangs - OSExec(): Failed to exec 0 in 1033

Added by hatarumoroboshi over 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
Launch Wii Sports Resort, after the short playable intro of diving from the airplane, get in the "welcome screen" (where you have to press A+B or select the instructional video at the top right of the screen) and choose to watch the instructional video; the game get stuck at 0 fps with the "black screen of death".

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
Every version that I've tried has this problem

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:
Windows XP SP3 32-bit - with every plugin or configuration option
Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
RZTE01

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?
normal iso

Please provide any additional information below.
The game also suffers from a lot of random freezes...

History

#1 Updated by averkov over 8 years ago

The problem is still not solved!

#2 Updated by Billiard26 over 8 years ago

  • Status changed from New to Accepted
  • Issue type set to Bug

Fyi, watching the videos work but choosing "Return to Game", "OK" will lock up with 0 fps.

The final log entry:
"Source/Core/Core/Src/HW/EXI_DeviceIPL.cpp:297 N[OSREPORT]: OSExec(): Failed to exec 0 in 1033"

#3 Updated by JMC4789 almost 7 years ago

  • Status changed from Accepted to Fixed

This works now and stuff. I'm guessing it was ES_Launch related.

#4 Updated by sgtflowerschris63B10 over 6 years ago

Does not work on mine. Not sure if it is the Wii Motion Attachment but when I connect it, the Game Freezes except for the Blinking "Watch Instructional Video". Remote is a RVL-003 with a Wii Motion Attachment RVL-027. When Attachment is removed, I can move the hand across the Screen and click on the Flashing Button. But when Attaching the Motion, it locks up again.

#5 Updated by sgtflowerschris63B10 over 6 years ago

Scratch that. Just Delete the following File: WiimoteNew.ini
Then, with the Motion+ Attached, startup Dolphin, Reselect Real WiiMote, then run WSR. Should work fine.

#6 Updated by JMC4789 over 6 years ago

Interesting; I had that issue for a long time too. Thanks for researching and explaining it :)

#7 Updated by sgtflowerschris63B10 over 6 years ago

Yeah I found it in the Dolphin Forum Thread for the Game. 5th Comment down. Only thing is, after not playing for a while, it will lose connection to the Remote and you have to Run the Game again.

Also available in: Atom PDF