Project

General

Profile

Emulator Issues #3625

Pixel Lighting + Specular Highlights Results in Dark Model Colors in Sonic Riders

Added by jayork42 over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
Enabling Pixel Lighting along with the recent specular highlights commit both restore full shine, but the models appear darker than they should be.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):

R6505

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:

WinXP Pro MCE x86

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

GXEE8P

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Compressed dump

Please provide any additional information below.

Screenshots:

http://i55.tinypic.com/334uds2.png
http://i52.tinypic.com/25uigeq.png
http://i55.tinypic.com/28jdtfo.png

Original comparison from Missing Shading Elements thread:
http://i28.tinypic.com/fy3gc1.png

With pixel lighting alone:
http://i52.tinypic.com/2dhe8u0.png

The last image shows pixel lighting is the cause of the problem.


Related issues

Is duplicate of Emulator - Emulator Issues #6169: Sonic Riders Lighting Highlights Fail to work in D3D11Fixed

History

#1 Updated by jayork42 over 9 years ago

I was thinking, maybe someone can make a super shiny hack out of this? It actually looks pretty cool, although it's not accurate.

#2 Updated by jayork42 over 9 years ago

While looking at the cutscenes I discovered this bug doesn't always occur. In the second Hero cutscene these 2 features actually work properly, and have more of a highlight than the actual game. Although this is different, and with pixel lighting the models look very good, it doesn't seem as accurate as with just specular highlights alone. Screenshot with all comparisons:

http://i53.tinypic.com/io2a88.jpg

The dark models problem seems to be more of a game issue now, since characters flash between normal and dark during races (as if some sort of fighting/clipping is going on).

#3 Updated by jayork42 over 9 years ago

Here's a video of the flickering problem.

http://www.mediafire.com/?zowrq616jhxc5ed

#4 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug
  • Category set to gfx

#5 Updated by NeoBrainX over 7 years ago

  • Status changed from New to Duplicate

JMC4789 said this is the same as 6169.. :p

Also available in: Atom PDF