Project

General

Profile

Emulator Issues #3627

EFB copies are incorrect aspect.

Added by chane2k1 over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

EFB copies are incorrect aspect when widescreen mode is enabled. The interesting thing is that it does look like its rendered at 16:9 but its squished to 4:3. Here are comparison shots widescreen http://members.cox.net/chane2k1/wide.png and standard http://members.cox.net/chane2k1/standard.png

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):

r6506 x64

Operating system and version:
32-bit or 64-bit:

64bit Windows 7 Ultimate

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
GXSE8P Sonic Adventure DX

Was the ISO a plain dump from disc, compressed and/or scrubbed?
plain dump then compressed with dolphin

Please provide any additional information below.
tried dx9, dx11 and opengl and all available combination of options.


Related issues

Is duplicate of Emulator - Emulator Issues #7128: Widescreen Hack Currently Performs PoorlyAccepted

History

#1 Updated by jayork42 over 10 years ago

I confirm this also happens with Sonic Riders, Super Mario Sunshine, Galaxy, and probably a lot of other games.

#2 Updated by hatarumoroboshi over 10 years ago

You mean the widescreen hack?

#3 Updated by Xtreme2damax over 10 years ago

Invalid issue, disable the widescreen hack. These games weren't designed or coded to be ran at any other aspect ratio other than 4:3, so anything outside the efb cutoff regions won't be rendered and will be stretched. This happens mostly in areas that use shader combiner effects, such are areas that have water.

The only fix is to disable the widescreen hack, so this issue is pointless. Read here as to why it is not possible to fix this issue, that is actually a non-issue considering the games weren't designed or coded to be run at a widescreen aspect ratio such as 16:9:

http://forums.dolphin-emulator.com/showthread.php?tid=9549&pid=121246#pid121246

http://forums.dolphin-emulator.com/showthread.php?tid=9549&pid=121336#pid121336

#4 Updated by chane2k1 over 10 years ago

Hold up, I believe it is a valid issue. I'm not saying the widescreen hack is supposed to look perfect. What I'm trying to show you is that the EFB copy IS in 16:9 but, it's being squished NOT stretched. Im sure this is fixable, pay attention to the 4:3 region in the widescreen image (it does render the extended geometry) don't worry about the outside boundaries. Look at the chairs at the top of the image as a guide they maintain the correct aspect and exact positioning in both shots.

#5 Updated by MofoMan2000 over 10 years ago

Just because the widescreen hack is a hack doesn't mean it can't be improved upon. This issue is just as valid as implementing a cheat search function (which I believe is issue 8), since AR codes are technically hacks too.

#6 Updated by Xtreme2damax over 10 years ago

It's an invalid issue, there's no way to fix it at all. The games simply weren't designed to be rendered at 16:9 widescreen resolution, and these glitches are normal.

It's a game design limitation, not a hardware limitation, therefore there is no way to fix it short of modifying the game's code. Read the links I posted, they are very informative and explain exactly why it's not possible to fix, specifically this:

"These games simply weren't made to render gfx outside of the 640/576i cut off points". Read what else was quoted in the reply I linked to above.

There's a few developers in the following thread that state why it's not possible to fix the issue, that's where I originally pulled the information from:

http://forums.ngemu.com/dolphin-discussion/135059-disable-culling-off-screen-geometry.html

Also consider that there were existing issues submitted prior to your issue, reporting the glitches with the widescreen hack that were marked invalid.

There's nothing left to discuss regarding this "issue", just disable the widescreen hack and set the aspect ratio in the graphics configuration dialog, as that's all that you can do since the glitches with the widescreen hack aren't possible to fix. It may not be true widescreen, but it's really the best that can be done for Gamecube games since they weren't designed for a widescreen aspect ratios/resolutions.

#7 Updated by chane2k1 over 10 years ago

Xtreme2damax I've read it and from what I've seen dolphin do, I don't believe it. We have had the EFB image shifted several times before just because it wasn't aligned. Im sure it can be stretched. Thank you MofoMan, you understand. Here's another shot, this time from Super Mario Sunshine where you can see what I mean http://members.cox.net/chane2k1/sms.png Hopefully in the future the widescreen hack will also be able toggle an EFB aspect stretch or something at the same time.

#8 Updated by MofoMan2000 over 10 years ago

Not exactly Xtreme. Rather than modifying the game, why not change the way EFB is handled when WSH is enabled? I'm not saying it should be perfect or that it needs to be, but it can certainly be changed. It's already a hack, so hack a workaround for Mario Sunshine. Even if there's no haze effect on the sides of the screen at least you wouldn't be seeing double like you do now.

#9 Updated by Xtreme2damax over 10 years ago

"Just because the widescreen hack is a hack doesn't mean it can't be improved upon. This issue is just as valid as implementing a cheat search function (which I believe is issue 8), since AR codes are technically hacks too."

Wrong, clearly you don't know what you are talking about. What part don't you understand about it being impossible to fix? Read the information I posted and stop blabbering about things you have no idea about.

This isn't like other issues which are only possible to fix because they're emulation issues that correlate with the hardware or existing features that overcome limitations of the actual hardware. This is not a hardware limitation or an issue with the emulated hardware, this is a limitation of the game design which can not be fixed short of modifying the game's code or altering elements of the games design. This is not only absurd due to the fact that the source code, original textures/models for the game would be needed (good luck convincing Nintendo and others to give that up) but it would be insanely time consuming as well.

Several experienced developers have stated this is not possible, and gave exact reasons why it's not possible for anyone that actually bothers to read the information I posted.

#10 Updated by Xtreme2damax over 10 years ago

I viewed the screenshots and that is the typical issue/glitch with the widescreen hack, and no it's not possible to fix.

This is the same issue as with ZTP due to the EFB cutoff regions and the widescreen hack, except the EFB region is being rendered is smaller with SA in that specific area so it isn't stretched across the screen.

Again read the information I posted.

#11 Updated by MofoMan2000 over 10 years ago

The solution is simple. Don't stretch it. Instead render it to the 4:3 area in the center of the 16:9 screen.

#12 Updated by MofoMan2000 over 10 years ago

I should clarify. This isn't a 100% fix, I perfectly understand there's no way to fix it perfectly, but it's better than seeing double (as in the case of Mario Sunshine).

#13 Updated by Xtreme2damax over 10 years ago

Actually this is the same exact issue that ZTP has with the widescreen hack, not possible to fix due to the fact the game wasn't designed to render anything outside the EFB cutoff regions.

Experienced developers even stated it's not possible to fix and gave in depth explanations why it isn't possible to fix. No need to continue insisting it's possible to fix when it clearly isn't, just ask the developers and they will tell you the same exact thing with the same reasons.

I am not sure how to get through to both of you considering information straight from the mouths of developers and the technical reasons given weren't enough to convince both of you.

#14 Updated by Xtreme2damax over 10 years ago

"The solution is simple. Don't stretch it. Instead render it to the 4:3 area in the center of the 16:9 screen."

Easier said than done, for technical reasons, the same reason the issue isn't possible to fix. It's not just a matter of not stretching the image, by definition the image is not actually being stretched. It's more like duplicate or excess efb data due to the games inability to render outside the efb cutoff regions when running in widescreen mode. This is purely an issue with the games design and can not be fixed by hacks even. Nothing short of altering the games code will fix it as I've already mentioned.

#15 Updated by MofoMan2000 over 10 years ago

Well, balls. I may not have any idea how it really works but I always figured EFB was rendered somewhat separately from the rest of the view, and if it were indeed rendered separately I imagine it'd be easy enough to fix that… And if the EFB weren't stretched across the entire screen it would be a lot more tolerable.

Like I said, I understand it's impossible to fix perfectly since most games weren't intended to render in widescreen under any circumstances (you'll occasionally find a GCN game with a widescreen option, like True Crime Streets of LA), for the same reasons widescreen hacks have issues in N64 emulation.

#16 Updated by chane2k1 over 10 years ago

Xtreme2damax the widescreen hack is clearly allowing the EFB to capture the new extended resolution, when the hack is disabled it grabs the original 4:3 image. Why can't we have the EFB capture locked to 4:3 when the hack is enabled. Seems completely possible considering the hack allows it to copy a larger region when enabled.

#17 Updated by NeoBrainX over 10 years ago

Uh, guess what: X2d's right ;)
You can't "fix" this without breaking other stuff. Simple as that.
It's called "hack" for a reason anyway :P

#18 Updated by NeoBrainX over 10 years ago

  • Status changed from New to Invalid

#19 Updated by chane2k1 over 10 years ago

well ill take your word for it neobrain i respect the work you've done. it's too bad that i can't code in cpp i'd like to take a shot at it at least. maybe once i'm done paying for school ill go back and learn how to code and surprise everyone with an enhanced hack. thanks again for all the work you've done on the video plugins.

#20 Updated by MayImilae about 7 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF