Project

General

Profile

Emulator Issues #3735

Mario Kart Double Dash speed is messed up in the latest releases.

Added by otomospirits almost 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

With MKDD the following behavior can be observed:

FPS:30 VPS:60 SPEED:100%

In which the FPS counter (and the pairing game speed) is locked to a maximum of 30fps (sometimes 45) all the time and in all places but title and menu screens.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):.

behavior can be observed in the latest releases up to svn 6633

(optional) Dolphin version that does not have the problem:

last working version I have is 6383 but could have started happening in a much later version, I first took notice of it in 6591 because the old standing bug of music stopping didn't happened on that, but lower than expected FPS made it unplayable.

Operating system and version:
32-bit or 64-bit:

WinXP 32bit.
CPU speed: 3.8ghz
RAM: 4gb
Video: Radeon hd 4650.

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

GM4E01

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Plain dump.

Please provide any additional information below.

6633 was tested with all settings default, no setting seems to have an effect on it and it is the only game so far with such behavior, every other gc game tested including star fox assault and zelda wind waker work as intended.

History

#2 Updated by xenofears almost 10 years ago

Tales of Symphonia has problems like this as well (NOT intentional frameskip/interlacing/whatever else, it goes WAY too slow, and the ratio is locked,) happens at battle results and sometimes during battles. I have seen it do 20:60 as well at battle results. The World Map is 30:60 but seems full speed.

AFAIK these are active fifo issues, and there's an open issue for this.

#3 Updated by hatarumoroboshi almost 10 years ago

Just tried a "quick race" r6633 (e8400, hd4850 WinXP SP3 32bit) and I have full 60 fps in race...I think the problem is that the "speed indicator" shows always 100% even when the game has some (rare) slowdown...in fact when the game drops for example to 50 fps, it doesn't show 83% but it's stuck with 100%...

#4 Updated by gamedevistator almost 10 years ago

I have the same problem and also when you are racing the music is low and stops after a while but you can still hear the sound effects.

#5 Updated by xenofears almost 10 years ago

The speed % is based on the VPS not FPS. If it's 50PAL/60NTSC it'll show as 100%. This confused me at first too. To change this the code would need to know what the fps:vps ratio is supposed to be and I don't think there is any way for it to know this, and it would be messy to implement.

#6 Updated by marcosvitali almost 10 years ago

This game WORKS PERFECT!!!! Please check you configuration. There no slowdons.

#7 Updated by otomospirits almost 10 years ago

xenofears It definitely is not a PAL/NTSC issue, the very same iso works 60/60/100% on version 6383 and will work 30/60/100% on 6633, in fact NTSC MKDD has never been a 30fps (at least for me) game like Luigi's Mansion or Super Mario Sunshine.

@Marcos as I said it's the only game I have that displays this issue but there are now other reports of overall slowness in this and tales of symphonia, it might be worth having a look at it.

I would agree you that it is a problem with my setup and not the revision if other games like starfox assault weren't 60/60, as I said I have messed up with every configuration available on dolpin, and still no change, maybe it's a 32bit only issue?.
Nevertheless if can and would suggest any change I should try to discard this up I'm open to suggestions.

#8 Updated by hatarumoroboshi almost 10 years ago

I Don't think it's a 32bit issue, because I have WinXP 32bit and for me the game is almost perfect...

#9 Updated by otomospirits almost 10 years ago

with 6652 MKDD is now working properly but only with D3D9 and copy to texture enabled. It still locks to 30 frames per second and displays the weird 30/60/100% with copy to ram selected (shouldn't it be more like 30/30/50% ?).

With opengl it is broken with either to-ram and to-texture selected.

Oddly enough Star Fox: Assault works full speed with both plugins and both copy to ram and copy to texture.

#10 Updated by maurocds almost 10 years ago

yep, me too on 6880 32b dx9, but playing on dx11 fix the framerate, 60fps again

#11 Updated by hatarumoroboshi over 9 years ago

Correct me if I'm wrong, but I think that this issue is now fixed...

#12 Updated by NeoBrainX over 9 years ago

  • Status changed from New to Fixed

No additional answer => fixed

Also available in: Atom PDF