Project

General

Profile

Emulator Issues #3775

Wii Sports Resort it's more slow in r6668 than 6659

Added by danielfrancosantana over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
Wii Sports Resort is more slowly in r6668 than r6659

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
R6668

(optional) Dolphin version that does not have the problem:
r6659

Operating system and version:
32-bit or 64-bit:
Win 7 64 bits

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
RZTP01

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Please provide any additional information below.
I use this config for optimal speed:

[Core] Values set here will override the main dolphin settings.
CPUThread = 1
SkipIdle = 1
BlockMerging = 1
TLBHack = 0
FastDiscSpeed = 1
BAT = 0
MMU = 0
[EmuState] The Emulation State. 1 is worst, 5 is best, 0 is not set.
EmulationStateId = 4
EmulationIssues =
[OnFrame] Add memory patches to be applied every frame here.
[ActionReplay] Add action replay cheats here.
[Video]
EFBToTextureEnable = 1
SafeTextureCache = 0
ProjectionHack = 0
EFBCopyEnable = 1
EFBAccessEnable = 0


Related issues

Is duplicate of Emulator - Emulator Issues #2811: Wii Sport Resort Tennis Table - framerate dropFixed

History

#1 Updated by school.player over 9 years ago

FAIL. Wii Sports Resort needs more than one CPU thread to run fast... actually, every game does.

#2 Updated by danielfrancosantana over 9 years ago

CPUThread = 1 it's dual core enabled in INI

#3 Updated by hatarumoroboshi over 9 years ago

Are you sure? How many fps? In wich "sub-game"? I didn't notice any regression in speed in this game...

#4 Updated by danielfrancosantana over 9 years ago

In table tennis I have more slowdowns with 6668 than the 6659 with the same config (INI) fle. The FPS aren't constant but decreases more in this last revision.

Before the game decreases to 44fps and now to 38. Before was playable, with 6668 runs slow.

MY SPECS: Phenom X2 BE 550 unlocked to X3, 4 gb ram, geforce 8600gts, real new "wii remote plus"

#5 Updated by hatarumoroboshi over 9 years ago

I had/have huge slowdowns in table tennis in every revision...I think this particular "sub-game" is still a bit complicate to emulate smoothly...and the other "sub-games" are playing at the same speed as before?

#6 Updated by danielfrancosantana over 9 years ago

With R6659 table tennis slowdowns don't be apreciate. As I say the game "was" playable. Basket throw is a little slow too, (approx, 3fps). Other mini-games not tested.

#7 Updated by hatarumoroboshi over 9 years ago

I've just tried table tennis with r6659 and r6669: with my system (e8400 - Hd4850 - WinXP 32 bit - real wiiremote plus) I have almost the same fps drops (minimum fps 40 with both revisions). Could it be a 64 bit issue?

#8 Updated by danielfrancosantana over 9 years ago

Could be. I always use the 64 bits version because the 32 bits version runs slow for me.

#9 Updated by daws72 over 9 years ago

check issue 2811, I got the same problem on table tennis

#11 Updated by hatarumoroboshi over 9 years ago

Maybe this issue should be merged in issue 2811

#12 Updated by Anonymous about 8 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF