Project

General

Profile

Emulator Issues #3866

Emulated Wiimote with mouse

Added by justin.sweglar over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Controls
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
Yes
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have 2 different issues with it.

One is I the alignment at top and bottom of screen mostly. But I noticed one game that aligned wrong left to right. But top to bottom the cursor wasn't spot on. The further up the screen you went the more unaligned it is but if you bring it back to dead center it's back aligned and opposite if you bring it down. More noticeable in full screen.

The second issue has to do with full screen itself. A normal wiimote you can just move off the side of the screen. But an emulated one you can not even moving it to the edge of the screen has no effect. I have to play some games in a window because it wont play with out moving the cursor off the screen. (maybe add a cursor off at edge for full screen option)

Using r6767

History

#1 Updated by skidau over 9 years ago

With the first issue, make sure that the sensor bar setting is set to "Top" and adjust the Center, Height and Width settings in the Wiimote settings.

#2 Updated by gabrielmorano over 9 years ago

There is an option to set the wiimote "offscreen" in the emulated section...

It's on the "IR" Tab "Hide"

As for the first issue menthioned, i really don't get quite right what you mean :S the Ir pointers seems to work perfect on every game to me

Also, wich game are you refering to?

#3 Updated by gabrielmorano over 9 years ago

also if you refer to games that need to have the wiimote offscreen in a sideways position, there is an option for that too...

#4 Updated by justin.sweglar over 9 years ago

Hmm. I thought Billard combined the wiimote plugins into one. Anyways the plugin I ran into those problems were with the Original plugin.

After switching the "new" one has similar issues.

For some reason the auto detect was detecting my mouse as a joypad. Making the IR pointer axis instead of cursor or mouse. But I finally figured out how to setup the cursor manually. Interestingly enough the Tilt actually has Mouse Y+ Y- but when I went through the list I could only find cursor Y+ Y- which worked so shrug Mouse on the tilt doesn't do anything.

It did however make the problem more noticeable. Where you take mouse to top of the screen and bottom it still is out of sync with the cursor.

After abit of testing I found that
The legend of Zelda Twilight Princess. I was unable to move the cursor all the way to the top bottom left or right.
Super Paper Mario the mouse was so out of sync that I could move the game cursor out of the screen before the OS cursor.
Super Mario Galaxy uses the mouse cursor perfect.
Maybe some sorta resolution issue between the games? I could I guess hide the mouse cursor and it'd be less noticeable. But still seems off to me. Maybe its some sorta acceleration thing?

The IR hide did work... But you have to hold the button, and you'd have to hold it the whole game(Super Paper Mario) and I do have it in sideways mode. Because its out of sync it actually puts the cursor off the screen making the game run how I like it but also very sensitive.

I'd like to see a 1 to 2 pixel off screen buffer on the edges so you can take it off screen.

#5 Updated by gabrielmorano over 9 years ago

the problem is that if you set those 2 pixels to get the cursor out of screen it will make games like metroid prime harder to play (as you turn same around by reaching the edge of the screen but not getting out of it) in that case what it can be done is changing to have an option in the "HIDE" button to make it "Hold" or "Switch"
so in switch mode you just press it once and it keeps pressed by itself then you press it again and it's released

that would "solve" your problem

#6 Updated by justin.sweglar over 9 years ago

The real wiimote would normally go off the screen while turning in metroid. But I suppose if it causes problems you could make it a option. I don't like the idea of having to press an extra button just to do it. But a selectable option to turn it on or off wouldn't be bad.

#7 Updated by Billiard26 over 7 years ago

  • Status changed from New to Invalid
  • Category set to controls
  • Relates to usability set to Yes
  • Operating system N/A added

The mouse cursor cannot be perfectly aligned with an in-game cursor without settings to tweak it.
I don't think we want edge-of-screen to simulate pointing away from screen.

There is another issue for a "Hide IR" toggle option so holding a button is not required.

Also available in: Atom PDF