Project

General

Profile

Emulator Issues #3914

Enabling OpenCL causes graphical glitches in Sonic Adventure

Added by jroseff over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

As the summary says, enabling OpenCL causes graphical glitches in many of Sonic Adventure's menus, stages, etc.

The most obvious example is of the main menu:

http://dl.dropbox.com/u/8706979/sonic_menu1.png (OpenCL enabled)
http://dl.dropbox.com/u/8706979/sonic_menu2.png (OpenCL disabled)

This also occurs on other menu screens:

http://dl.dropbox.com/u/8706979/sonic_menu3.png (OpenCL enabled)
http://dl.dropbox.com/u/8706979/sonic_menu4.png (OpenCL disabled)

A few textures in levels appear to be affected as well. I don't have a comparison for this, but it looks like water textures were swapped with grass textures here: http://dl.dropbox.com/u/8706979/sonic_grassywater.png

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"): 6836

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:

Mac OS X 10.6.6 (10J567), 64-bit binary and kernel

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"): GXSE8P

Build command-line (not on Windows):

gcc(g++)-4.2 -ObjC(++) -o (file) -c -O3 -fomit-frame-pointer -fno-exceptions -fno-strict-aliasing -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter -Wpacked -Wpointer-arith -Wshadow -Wwrite-strings -arch x86_64 -mmacosx-version-min=10.5.4 --sysroot=/Developer/SDKs/MacOSX10.5.sdk -msse4.1 -Xarch_x86_64 -mtune=core2 -iframework/Developer/SDKs/MacOSX10.5.sdk/System/Library/Frameworks -iframework/Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks -Wextra-tokens -Wnewline-eof

Was the ISO a plain dump from disc, compressed and/or scrubbed? dump

Please provide any additional information below.

Possibly also affects other games.


Related issues

Is duplicate of Emulator - Emulator Issues #3731: opencl pixelates some texturesWon't fix

History

#1 Updated by jroseff over 9 years ago

I haven't played this on a real console in probably 8 years, but I'm guessing this is a bug in Dolphin (if it's not then Sega should probably fire their entire QA department), best described by this animation: http://j.ig42.org/masteremerald.gif

OpenCL wasn't enabled, though. For the uninitiated/lazy, it's a cutscene where a character is supposed to be carrying something central to the plot, but very clearly isn't. I wasn't able to figure out a combination of settings that would make it show up, either.

#2 Updated by knuckles500 over 9 years ago

Don't worry, it looks like that on every version of Sonic Adventure I know. :P

About the issue itself - I'm using r6839 x64 and the OpenGL plugin and I can't get the problems you're having with OpenCL enabled. However, I'm on Windows 7 - so that might not help much. :\

What video card are you using?

#3 Updated by jroseff over 9 years ago

It's a GeForce 8800 GT flashed with an EFI ROM. I'll give it a shot on my MacBook later today to see if it'll happen on its 9400M/9600 GT.

#5 Updated by Xsacha over 9 years ago

Just a note that those last links don't work :P But I guess they look the same as the top ones.

Are you able to test this on an ATI card? I only have ATI cards available. But I don't have this game 'Sonic Adventures'. If it's confirmed bugged on ATI too, I will be able to fix (without having this game).

I think it is perhaps Nvidia only.

#6 Updated by jroseff over 9 years ago

Sorry, the links should work now (but yeah, they're basically the same as the other shots). I'm in the opposite situation as you though, I only have Nvidia cards :\

I'm not sure what card knuckles has, but he mentioned he was using Windows - maybe it's an OS X issue?

#7 Updated by jroseff over 9 years ago

Managed to borrow someone's iMac, I can confirm that this does NOT happen on a Radeon 2600 Pro (under OS X 10.6.6).

#8 Updated by nuyrul over 9 years ago

I think this is the same as issue 3731. It's an Nvidia problem.

#9 Updated by soren.jorvang over 9 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF