Project

General

Profile

Emulator Issues #4146

Mamario's builds on the official website are randomly broken (VS2010 issue?) - games crash soon after boot

Added by gflas over 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I'm unable to run any (wii/gcn) game on new revisions.

I'm using Dolphin r7223 for Windows 7 x86

The Dolphin r7129 (which is not in archives for some reason) doesn't have this problem

ANY game (MSM, NSMBW, PMTTYD, SMG, SMG2, SPM) doesn't work

All of them were compressed (.gcz)

Tried to check some options like double core, using no adiuo, etc.


Related issues

Has duplicate Emulator - Emulator Issues #4148: No games work whatsoeverDuplicate

Has duplicate Emulator - Emulator Issues #4149: Games will not load on r7167 onward.Duplicate

Has duplicate Emulator - Emulator Issues #4150: crash issue on Windows 7 x64 with Dolphin-win-x64-r7224Duplicate

Has duplicate Emulator - Emulator Issues #4153: Dolphin Crashes When Game StartsDuplicate

History

#1 Updated by Anonymous over 8 years ago

  • Status changed from New to Invalid

#2 Updated by DimitriPilot3 over 8 years ago

No problem with SMG1 (game ID: RMGP) and SMG2 (game ID: SB4E), using my own compiled VS2010 build...

#3 Updated by DimitriPilot3 over 8 years ago

However, this crash occurs in Mamario's builds of r7222 and r7223 (for x86 at least).
Could that be an issue with VS2010? Using "Build All" can cause this issue, whereas "Rebuild All" doesn't...

#5 Updated by gamedevistator over 8 years ago

yeah i have this issue too. The game starts then it instantly crashes doesn't what game or how i configure it.

#6 Updated by raphaelcorrea007 over 8 years ago

Wow, i just downloaded dolphin for the first time today and thought I was the only one with this problem. Btw it seems to have extended into x64 as SSBM, only game I have so far will load then instantly crash. I am also running r7223

#7 Updated by DimitriPilot3 over 8 years ago

  • Operating system Windows added

Yet another issue title modification... I hope this is the last time...

#8 Updated by DimitriPilot3 over 8 years ago

issue 4150 has been merged into this issue.

#9 Updated by Anonymous over 8 years ago

issue 4148 has been merged into this issue.

#10 Updated by Anonymous over 8 years ago

issue 4149 has been merged into this issue.

#11 Updated by Anonymous over 8 years ago

issue 4153 has been merged into this issue.

#12 Updated by gflas over 8 years ago

I want this issue to be reopened. r7232 (latest) has this issue as well.

#13 Updated by Xtreme2damax over 8 years ago

There is no issue, the issue is with mamario's build environment and something he will need to fix. The developers cannot fix it as it isn't a problem with the code or any commit.

#14 Updated by Xtreme2damax over 8 years ago

Forgot to mention, just use a build from another member for now until mamario can fix his setup for builds.

Also available in: Atom PDF