Project

General

Profile

Emulator Issues #4364

Incorrect Shading on Cel-Damage

Added by whyischris almost 8 years ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-5934

Description

What's the problem?
Cel-Damage renders pretty much everything that moves without textures or colours. The design of the game has a cel-shaded look to it so I'm not even sure if it uses textures.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
All of them.

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:
Windows 7 64 bit

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
Pal version is GCLP69, NTSC is GCLE69.(I believe I'm using the PAL version, I'll get back to you on this.)

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?
Plain dump ASAIK

Please provide any additional information below.
I have tried using all 3 graphics drivers, My system is an ATI5850 with the latest drivers, all 3 give the same results. Please note you must turn on accurate texture cache for it to not crash dolphin on the intro.

GCLE69-2.png (967 KB) GCLE69-2.png seapancake, 06/23/2016 02:00 PM
GCLP69.dff (1.55 MB) GCLP69.dff seapancake, 06/23/2016 02:04 PM
5465

History

#1 Updated by whyischris almost 8 years ago

Just checked and I am using the PAL version.

#2 Updated by G.Alex.Levy over 7 years ago

I'm having the same issue and would also like to know what to do, anybody that can help?

#3 Updated by whyischris over 7 years ago

Not that anyone has taken any interest in this issue but I'm also not sure if it is the place to ask for help either. I'm not bagging you out, I am just not sure of the rules. Probabyl the best place place for discussion if you are not a dev is the forums, however if you have the time you could try to produce debug logs of what happens when the game is running and post it here.

This may help the devs take interest in this issue. I would do it myself but I've been super busy recently, Working and getting married etc...

#4 Updated by NeoBrainX over 7 years ago

There have been various gfx fixes recently, is this still an issue?

#5 Updated by whyischris over 7 years ago

Yes it's still an issue, I posted about it to the game discussion thread the other day when I was at work and someone else checked, but I've just checked right now with mamarios 3.0-147 which is 2 revisions ago from the master branch and still have the same problems.

#6 Updated by NeoBrainX over 7 years ago

  • Status changed from New to New

#7 Updated by whyischris about 7 years ago

I've just tried it again for the first time in a while, this time on v3.0-415, mamarios build. You can now see the textures however they aren't right exactly, saturation looks blown out and transparency can be seen on the overlapping edges of each layer.

Also, something has caused in game problems, where you fall through the floor where ever you are placed and die repeatedly.

#8 Updated by NeoBrainX about 7 years ago

The last thing you mentioned sounds like a PPC emulation problem, could you do some regression testing to find out what commit caused that behavior?

#10 Updated by NeoBrainX about 7 years ago

Uhm, possible revision ea2e0e90633535112c95e999634b1bb1111a98bd then? I don't think any of my texcache related commits would cause that.

This is kinda unrelated to the actual issue, but CCing skid anyway...

#11 Updated by whyischris about 7 years ago

Cool, I'm just glad it only happened recently, I was not looking forward to going back to find it. Incorrect Texture/Shading issue still stands but colours are wrong. Gameplay is another problem...

#12 Updated by whyischris about 7 years ago

So do you think the texcache branch somewhat fixed the textures but this other issue was introduced by skids commit? Is there any other info you need that I haven't provided?

#13 Updated by whyischris about 7 years ago

Realising the numbering structure of mamarios builds I now beleive that the texture issue was introduced/"fixed" from a commit within the texcache-preload branch. I'll go back tonight and test each build from 413 back to 410 to find it. I'll also check to see if the fall-through-floor was present in 409.

#14 Updated by parlane about 7 years ago

We are most interested in the fall through floor issue TBH, as it's more likely PPC related than gfx.

#15 Updated by whyischris about 7 years ago

Righto, so when I find out should I create a new issue or just report my findings here?

#16 Updated by parlane about 7 years ago

Here is adequate, skidau is watching anyway.

#18 Updated by NeoBrainX almost 7 years ago

Could you provide a FIFO log of one frame in the game where the issue is visible?

#19 Updated by whyischris almost 7 years ago

Is this what you mean? It's for the textures right?

#20 Updated by The7thColumn almost 7 years ago

Can I go to a previous build to make this work?

#21 Updated by whyischris almost 7 years ago

You're welcome to test, but You may have to back around release of 2.0 But if you read above, it's kind of pointless as that fall through the floor thing has always happened - to the best of my knowledge.

#22 Updated by parlane almost 7 years ago

"It's for the textures right?"

It records all graphics, it records the gfx pipeline basically.

#23 Updated by whyischris almost 7 years ago

Ah I see, so is the file uploaded above acceptable then or will I need to do it again?

#24 Updated by whyischris over 6 years ago

@Just wanted to check parlane, was that file any help? I've just tested the latest revision and the issue is still there, it happens in all video backends including software so I guess it is PPC related - not that I know what I'm really talking about.

#25 Updated by NeoBrainX about 6 years ago

The file is okay. Just needs someone to actively work on the issue :p

Fwiw, sure that the software backend is affected? From my limited testing it seemed as if the software backend was doing fine apart from minor issues. It at least didn't have as bad saturation as the hw renderers.

#26 Updated by whyischris about 6 years ago

Yeah, it seems the software backend has less saturation, it's below what I would say is normal. It's like DX9,11 and OGL are too bright and software is too dark. The falling through the floor issue remains, so still unplayable. I am currently testing on 3.5-78. Will have to check the latest revs.

#27 Updated by Billiard26 almost 6 years ago

  • Issue type set to Bug

#28 Updated by MayImilae over 5 years ago

  • Category set to gfx

#29 Updated by skidau over 4 years ago

Here is a comparison screenshot between Dolphin and the Wii:

http://screenshotcomparison.com/comparison/88961

#30 Updated by JMC4789 over 4 years ago

  • Status changed from New to Accepted

#31 Updated by whyischris about 4 years ago

Just wondering, is it possible this issue is related to lighting attenuation? I tried PR#1941-latest but there was no difference.

#32 Updated by seapancake over 2 years ago

5465

Did some testing on this...

  • Occurs in D3D11/12 and OGL
  • Broken in 4.02 all the way up to 4.0-9503
  • Tested various graphic settings but made no difference

#33 Updated by seapancake over 2 years ago

1 frame FIFO log.

#34 Updated by JMC4789 about 2 years ago

Pull Request 4598 allows us to record this glitch in fifologs, hopefully will lead to this bugs eventual demise.

#35 Updated by JMC4789 about 2 years ago

  • Status changed from Accepted to Fix pending

Fixed in Pull Request 4601

#36 Updated by JosJuice over 1 year ago

  • Fixed in set to 5.0-5934
  • Status changed from Fix pending to Fixed

Also available in: Atom PDF