Project

General

Profile

Emulator Issues #4460

pokemon snap won't recognize pictures

Added by psionx12 about 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
the game actually has the red dot unlike the n64 version but I can't submit pictures to be rated by prof oak even though I can see them on the screen. I've tried every video setting I can think of.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):Dolphin-x64-r6758

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:
win 7 home premium x64
Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"): NAKE
Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Please provide any additional information below.

History

#1 Updated by MofoMan2000 about 10 years ago

Enable CPU access to EFB? I dunno, this is an interesting one, PJ64 doesn't even do as well as that. If you can bear incredible slowness for a while, can you see if it works in interpreter mode? Starred.

I'm sure Jabo and Zilmar have their reasons, but things like this just go to show the obvious benefits of an open source emulator.

#2 Updated by Xtreme2damax about 10 years ago

This sounds like the same type of issue as in ZWW with accepting the pictograph photo's. Try enabling Copy EFB to Ram if you haven't tried that yet.

#3 Updated by psionx12 about 10 years ago

copy EFB to ram was already on and my system can't handle interpreter mode even though I have a 6mb core 2 duo processor. I only have an intel gma4500HD video card and 4 gigs of ram on my laptop. it's hard to believe that i'm having a harder time playing an n64 game than I do ps2 and dreamcast games.

#4 Updated by Sonicadvance1 about 10 years ago

One, Interpreter is never meant to be fast, it's just for testing to see if it works in interpreter or not, if it DOES work in interpreter, that can narrow it down for the developers. If you REALLY REALLY want to play a Nintendo 64 game, you should probably play it in a Nintendo 64 emulator. Not a Gamecube emulator emulating a Nintendo 64.

#5 Updated by school.player about 10 years ago

Same here with SSBB custom stage previews, but ONLY if the stage was created in Dolphin. The stages that come with the game and stages created on a real Wii both work fine.

#6 Updated by rdragoon over 9 years ago

After waiting 4 hours to reach the end of the first level, this problem still exists when ran with the interpreter.

#7 Updated by rayfoxii over 8 years ago

This game was never fixed in any n64 emulators so it'd be nice to see it working with dolphin. The n64 emulators had the same problem in not being able to select pictures, but they got around it with a cheat code you could enter that would fix it. The n64 versions had other problems that dolphin doesn't seem to have though.

#8 Updated by danialhorton over 8 years ago

emulating an emulator

lulz

#9 Updated by JMC4789 over 8 years ago

I played this game in the emulator with EFB to ram on, and I've noticed that it's actually different than in the N64 emulators. The problem isn't in the pictures being taken, or even in viewing them.

In EFB to texture, it does not detect what you're seeing and softlocks because there is a scripted sequence at the beginning of stage one. This is because it's meant to see three pokemon and force you to use the controls.

EFB to Ram detects the pokemon, and detects that you're shooting them and the stage plays as normal. But somewhere along the lines, that data gets lost or isn't saved, because the problem is that when you see the pictures in Oak's lab, it doesn't know that there's a pokemon in the picture, effectively giving you 0 pokemon to choose from. This cannot happen in stage 1 on the Wii, because you automatically have 3 images from the first 3 pidgeys.

For people who absolutely want to play it on emulator, project 64 and Mupen 64 with Glide64 Napalm will run the game fine under certain settings. Otherwise, just stick to the Wii for now

#10 Updated by link_971 over 8 years ago

Is it possible to fix this issue ?
We can't finish Pokemon Snap on any N64 emulators, because there are a problem with the red dot of the camera...

Even a cheat code or any hack, but please, you can find a solution, for we, Pokemon fans ?

Thanks in advance guys...

#11 Updated by NeoBrainX over 8 years ago

link_971: Stop spamming the issue tracker, this isn't a support forum to get all your issues fixed. If you have nothing to say which directly helps solving the issue, keep it to yourself. Thanks.

#12 Updated by rachelbryk over 8 years ago

  • Issue type set to Bug
  • Category set to gfx

Turns out he did help, by reminding me of this! This game works fine in software renderer.

#13 Updated by JMC4789 over 7 years ago

  • Status changed from New to Accepted

This should be accepted or something. I tried this in Tev_Fixes_New, but it didn't seem to help, unfortunately.

#15 Updated by phire almost 7 years ago

I tried software renderer last night and it was back to "stuck in tutorial mode".

I was thinking on the way to work that it might be a gpu sync problem. I had software renderer running in dual core mode, I wonder if single core mode with efb copies. would fix ogl/dx backends?

#16 Updated by JMC4789 almost 7 years ago

PhireN: What happens is that the game has a built-in frameskip, and if you run it so slow, you'll miss the pokemon that trigger the tutorial.

#17 Updated by rachelbryk almost 7 years ago

No, i've only ever tested this with single core.

#18 Updated by JMC4789 over 6 years ago

https://github.com/galop1n/dolphin/commit/8128018a422e4da2ae1054844a2dcd7ade1310a0

This is the real commit that fixes it now. I had to check the WIP branch to find it. I tried merging it into master to pull it apart but holy crap that's not working out.

Pinging more people to dig through it and find what fixes Pokemon Snap.

I did get this commit compiling after fixing a build error in visual studio, and I did confirm with bisecting this one fixes it.

#19 Updated by degasus over 6 years ago

@jmc: this commit is worthless, it's his all-in-one commit.

#20 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF