Project

General

Profile

Emulator Issues #4502

Critical: Dolphin Constantly Hangs Windows

Added by jayork42 over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
When playing Gamecube games, Dolphin frequently freezes and causes Windows to be completely unresponsive.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):

7540

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:

Windows XP Pro MCE x86

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

GM4E01, GTYE69, possibly others

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Compressed dump

Please provide any additional information below.

This problem first appeared when upgrading my PC. Everything was swapped out new. I have a feeling the problem is the video card (Geforce GT 240) or my drivers. When this happens Windows can become responsive again, but only briefly. Sometimes the game will resume, and somtimes it will resume with corrupt on-screen textures or mismapped textures of 3D elements. I am of course unable to capture a save state or FIFO frame of this because it locks up Windows. I have only tested this with Mario Kart Double Dash and Ty the Tasmanian Tiger for Gamecube. I have only tested Gamecube games running under DX9. I'll do more testing on this to see if I can narrow down the problem.

History

#1 Updated by hatarumoroboshi over 9 years ago

If you think it's a problem related to your system, why did you open a Dolphin issue?

#2 Updated by jayork42 over 9 years ago

I'm not sure that it is. Does anyone else have this problem?

#3 Updated by NeoBrainX over 9 years ago

  • Status changed from New to Invalid

Dolphin doesn't cause system hangs out of nowhere. Got to be some driver problem, like you suggested. Nothing we can do about it, sorry.

#4 Updated by jayork42 over 9 years ago

It clearly does, look around for the countless threads on GeForce GT 240 problems.

#5 Updated by mickamartel over 9 years ago

it doesn't. DOlphin runs without crashes and freezing on MKDD.

Surely a problem with drivers or other (with the gt 240 maybe, like you suggested, but with my hd 4890, nothing like that)

Also available in: Atom PDF