Project

General

Profile

Emulator Issues #4552

DSPHLE's audio dumper mangles output audio

Added by jayork42 about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
When listening to the output audio after dumping an audio sample, the timing of sounds and music is off, making it impossible to use the audio stream for anything. This changes the timing of audio events, making it impossible to be used with accompanying video dumps because of bad audio/video desync.

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):

7571

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit:

WinXP Pro MCE x86

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

Any game

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Both

Please provide any additional information below.

Here's a sample of the Mario Kart Double Dash theme music. The first sample you hear is from the Gamecube, the second one is from Dolphin. Please note that during real time emulation the music sounds just fine, it's only when playing back recorded audio from DSPHLE that the problem starts.

http://www.filefactory.com/file/cb8861d/n/test.wav


Related issues

Is duplicate of Emulator - Emulator Issues #4452: DSP HLE has various instances of producing the wrong and/or no outputInvalid

History

#1 Updated by jayork42 about 9 years ago

Actually, mark this one as invalid. I forgot HLE isn't supported anymore, and dumped audio is literally perfect using the LLE recompiler.

#2 Updated by LM1234 about 9 years ago

  • Status changed from New to Duplicate

#3 Updated by DimitriPilot3 about 9 years ago

I'd say HLE audio emulation is "barely supported nowadays", not that HLE is "no longer supported".

But still, in games such as NSMBW or SMG, non-sequenced (pre-rendered) music is usually played at the same "speed" regardless of VPS, as opposed to sequenced noises/music. Thus, when dumping into full speed, you won't get the same accuracy with HLE audio rendering (wherein sounds tend to be desync'd) than with LLE.

#4 Updated by gabrielmorano about 9 years ago

The problem with LLE is that most of the times (even if you use the fast version of it) it's really slow compared to HLE

#5 Updated by jayork42 about 9 years ago

LLE should be much faster soon, the devs seem to be all over it now. It's gonna turn out to be great.

Also available in: Atom PDF