Project

General

Profile

Emulator Issues #4576

Resident Evil 4 crashes on castle puzzle

Added by minhty.baoshing about 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PPC
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
Resident Evil 4 crashes on the castle puzzle when you press the buttons

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"): R 7564

(optional) Dolphin version that does not have the problem:

Operating system and version:
32-bit or 64-bit: 64 - bit

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
RB4E08
Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

Please provide any additional information below.


Related issues

Has duplicate Emulator - Emulator Issues #5954: Resident Evil 4 (Disc 1)Duplicate

History

#1 Updated by DimitriPilot3 about 9 years ago

This seems to be a duplicate of issue 3027.

But is issue 3027 exactly the same issue as issue 2498?

#2 Updated by Carnifx almost 9 years ago

This needs sorted.

Yes, it is a dup of issue 3027, but NOT of 2498 (which is a completely different platform and issue).

Gamekiller.

#3 Updated by NeoBrainX almost 9 years ago

CC'ing skid, he should know why he merged issue 3027 into issue 2498 ;)

#4 Updated by wespipes69 over 8 years ago

Several people on the forums are still reporting this on latest revisions. Many have stated that switching to JITIL resolves the issue. Can we confirm that? Then adjust the bug title to reflect that.

#5 Updated by tommyhl2.SS over 8 years ago

Posting an NTSC memory card save near the area would be very helpful.

#6 Updated by tommyhl2.SS about 8 years ago

Still need that memory card save if possible.

#7 Updated by amiroim23 about 8 years ago

the JITIL Fix's the problem, and also, it works faster :)

#8 Updated by wespipes69 about 8 years ago

I don't know if it's faster anymore and I think the JIT is just more stable and actively being worked on. I never see anything about the JITIL anymore. Eihter way, that's just a workaround, not a fix.

#9 Updated by tommyhl2.SS about 8 years ago

If it wasn't obvious enough yet, post the memory card save if you've got it.

#10 Updated by wespipes69 about 8 years ago

All I can offer are these complete save files: http://www.wiisave.com/index.php?cid=118

From our wiki:
In version 3.0, the game consistently freezes when your character walks to the right button switch in the puzzle soon after the first mini-boss. This hang only affects the JIT recompiler engine, so two options are available: (1) switch to the JITIL recompiler for this one part, or (2) get Ashley to step on the plate instead.

Walktrough (Practice shooting section):
http://www.alteredgamer.com/resident-evil-4/40444-resident-evil-4-walkthrough-chapter-3/

#11 Updated by tommyhl2.SS about 8 years ago

Ah yes, I get this too. When i read the title "Castle Puzzle" I thought we were talking about the puzzle where you have to move the several tiles/squares around till you get the picture right. You also have to add your own small square to complete the puzzle.

This is the issue we're talking about: http://i.imgur.com/rsl3T.jpg

Touching/walking on the right yellow trigger causes the crash. I would post the save myself, but I've already passed that part and triggered the platforms.

#12 Updated by tommyhl2.SS about 8 years ago

For what it's worth, this is an issue as far back as r5000.

#13 Updated by Sonicadvance1 over 7 years ago

issue 5954 has been merged into this issue.

#14 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#15 Updated by tommyhl2.SS about 7 years ago

  • Category set to ppc

#16 Updated by wespipes69 almost 7 years ago

So is this fixed then? I saw another bug that looked identical and it was resolved as fixed.

#17 Updated by Zmotorola360 almost 7 years ago

i agree this is boring and i simply dont know how to use the "JITIL recompiler" to avoid the freeze :-(

#18 Updated by comexk almost 7 years ago

It's right there under Config.

However, if you get me a save state from right before the crash, I'll fix it on JIT.

#20 Updated by Zmotorola360 almost 7 years ago

i found it ! :)

"However, if you get me a save state from right before the crash"

tell me how to do then i will do it (i really suck at computer stuff, you would even have to teach me where to host the file ... it s my first pc ...

#21 Updated by abdwadams over 6 years ago

comexk, I have a save state but it's over 20 MB, even as a ZIP file. Please suggest a way for me to send it to you.

Thanks to everybody for your work on this emulator.

#22 Updated by wespipes69 over 6 years ago

Use Dropbox or Skydrive.

#23 Updated by doearticle over 6 years ago

Wespipe
Can you post here when a new Dolphin fixing this problem will be released?

(a direct link for download would be nice too)

Thanks for your efforts

#24 Updated by abdwadams over 6 years ago

comexk, here's the link to the saved state, I hope 4shared is ok for you. Sorry this took so long.
http://www.4shared.com/zip/ZxbyqaUdce/ResEvil4_state.html?

#25 Updated by markdperry68 over 6 years ago

comexk, have you had a chance to look at this?

Also a more general question: has anyone tried stepping on the LEFT yellow switch, leaving Ashley there, then go step on the right switch afterward? I admit I normally always did it the other way around.

#26 Updated by JMC4789 over 6 years ago

  • Status changed from New to Accepted

I found more reports of this, definitely a very annoying glitch. Is that savestate for the GCN version?

#27 Updated by mcamisk over 6 years ago

@mperry5 yes I have tried placing Ashley on the left switch first 5 times just to make sure and it still crashes when Leon nears the right switch.

#28 Updated by abdwadams over 6 years ago

@JMC4789 Yes that savestate is from the European version on Gamecube.

#29 Updated by JMC4789 over 6 years ago

Bleh, I'll have to get there myself; NTSC here.

#31 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF