Project

General

Profile

Emulator Issues #4636

Mortal Kombat Armageddon corrupted intro

Added by hung.up247 about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

Mortal Kombat Armageddon corrupted intro

Dolphin version with the problem : r7633 64bit

(optional) Dolphin version that does not have the problem: r7621 64bit

Operating system and version: Windows 7 SP1

32-bit or 64-bit: 64-bit

Game ID : RKME5D

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?

a plain dump from disc

Please provide any additional information below.

Intel GMA HD


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by florian98.rg about 9 years ago

Can anybody with a NVIDIA GPU confirm this ?

#2 Updated by hung.up247 about 9 years ago

Mortal Kombat Armageddon not only the intro became corrupted , all the game is corrupted too , bad work.....

#3 Updated by DimitriPilot3 about 9 years ago

  • Category set to gfx

What about you try a few builds and narrow this issue's "culprit" to one revision instead of complaining and assuming the breakage is due to the latest revision? Just stick with 3.0 if you want a stable Dolphin without suffering experimental changes...

It's mostly up to you (testers, contributors) to find out which changes broke what things in games. Developers usually do the rest if it's simple to fix.

#4 Updated by hung.up247 about 9 years ago

@DimitriP ok , thanks for your answer.

#5 Updated by hung.up247 about 9 years ago

ok, i just finished testing previous revisions and the problem starts from r7625.

#6 Updated by DimitriPilot3 about 9 years ago

  • Status changed from New to Duplicate

As I kinda suspected, it looks like one of those texcache-rewrite issues...

Feel free to compare the results using different texcache-rewrite builds (the first 27 ones listed) and hopefully narrow the "culprit" down to as few revisions as possible:
http://tinyurl.com/emucr-dolphin-texcache-rewrite

Also available in: Atom PDF