Project

General

Profile

Emulator Issues #4645

Fire Emblem:Path of Radiance missing portraits on Mac but not on Windows

Added by terence.tan about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?

Fire Emblem:Path of Radiance portraits do not appear

Dolphin version with the problem (as it appears in the title bar, Ex.: "R
4779" or "R 6403M"):
Mac version R7635
(optional) Dolphin version that does not have the problem:
Windows version (with DirectX) R7635...Portraits seem OK
Operating system and version:
32-bit or 64-bit:
Mac Snow Leopard. Mac Book Pro.

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):

Build command-line (not on Windows):

Was the ISO a plain dump from disc, compressed and/or scrubbed?
Dump from disk
Please provide any additional information below.


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by DimitriPilot3 about 9 years ago

Did you use the same (OpenGL) backend for testing?
Is this a "texcache-rewrite" issue? (see if the problem started with r7625, or see if it existed on "texcache-rewrite" builds and not on regular "trunk" builds before r7625: http://tinyurl.com/emucr-dolphin-texcache-rewrite)

#2 Updated by terence.tan about 9 years ago

I used the Direct3D backend on Windows. I tried the OpenGL backend on Windows and it gave similar (i.e. corrupt portraits) results.

The v3.0 Release doesn't have that problem on Mac (didn't test windows).

#3 Updated by Baagel.Noogan about 9 years ago

then this is an OpenGL texcache-rewrite problem, not just mac :)

#4 Updated by DimitriPilot3 almost 9 years ago

  • Status changed from New to Duplicate
  • Category set to gfx

Most likely. I dunno if this was already fixed by one of Nolan's commits (nor if this should be merged into a more specific texcache-rewrite OGL issue), though I guess it should at least be merged into issue 4635...

Also available in: Atom PDF