Project

General

Profile

Emulator Issues #4648

Metroid Prime 1 and 2 Texture load problem?

Added by MythofDrizzt about 9 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem?
-When starting Metroid Prime 1 or 2 I get a black screen, and if you enable 'show statistics' textures alive and textures loaded are both 0. However, I can click around and the game still acts like its running judging by the audio. I also get a flickering box in the bottom right corner of my screen.

Dolphin version with the problem:
-I have tried version 7613 through 7639 as well as the 3.0 release.

Dolphin version that does not have the problem:
-none for me.

Operating system and version:
32-bit or 64-bit:
-I am running x64 win7 ultimate, and have tried the x64bit version of 7613-7639, but I have tried the 32bit of 7639 to see if it was the x64 causing the problem.

Game ID (as it appears in game properties, Ex.: "GZ2P01" or "RSBE01"):
-Don't know where to find this..

Was the ISO a plain dump from disc, compressed and/or scrubbed?
-The mp1 ISO was a plain dump from disc, and the mp2 ISO says [ngc][pal]
Please provide any additional information below.
-AMD Athlon II X2 2.7ghz ; Nvidia GTS 450 ; 2.5 Gigs of RAM

This is what I see in the title screen, along with the music.
http://imageshack.us/photo/my-images/844/mp1notloading.jpg/

This is what I see once I start the game.
http://imageshack.us/photo/my-images/9/mp1ingamejpg.jpg/

History

#1 Updated by MofoMan2000 about 9 years ago

So this happens before r7625?

#2 Updated by Nick.Lustig about 9 years ago

Try what happens if you turn off antialiasing.
Because I have exactly the same problem in Ogl.
When I turn AA off then the game shows up like it normaly should do.
So in my opinion the AA feature is broken !

#3 Updated by Autoran1 over 8 years ago

Confirm this issue, i don't know why exactly this happens, cause it's pretty random and game can actually run normal after 1 or 2 restarts

#4 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug
  • Category set to gfx

#5 Updated by Billiard26 over 7 years ago

  • Status changed from New to Questionable

Is this issue present in Dolphin 3.5 or later?

#6 Updated by skidau over 7 years ago

  • Status changed from Questionable to Won't fix

Never seen this before. AA sounds like a possible cause, but since it is an enhancement, it is not surprising for it to break. Maybe it will work if the GC BIOS is not skipped.

Also available in: Atom PDF