Project

General

Profile

Emulator Issues #4654

Dragonball Z Budokai Tenkaichi 3: Heavy color-bug affecting sprites and textures (3d-textures work fine)

Added by greenarrowvigilante over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Look at the screenshots in the attachments. I randomly went back a few versions and it's fine with 7594. It's even worse with the newest builds.

The versions I've tested:

7594: fine
7634: Nope, color-offsets, look at the screenshots
7645-7647: Even worse. What's purple in the screenshots is a light green and you even see the bounds of the sprites in a greenish tone.

Using the D3D10-Plugin on Win7x64 and a 4870X2.


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by greenarrowvigilante over 8 years ago

Sorry, screwed up the releases-list:

The versions I've tested:

7594: fine
7634-7645: Nope, color-offsets, look at the screenshots
7646-7647: Even worse. What's purple in the screenshots is a light green and you even see the bounds of the sprites in a greenish tone.

However, the intro-video works fine on all releases.

#2 Updated by jim.lee.1688 over 8 years ago

Other games have a green light.

Direct3D9 plug-in problem, OpenGL plug-in is correct.

7446 fine
7679 problem

Operating system
WinXP 32
ATI HD 5770 drivers (Catalyst 11.6)

#3 Updated by greenarrowvigilante over 8 years ago

Can't confirm that OpenGL fixes this, budokai tenkaichi 2, 3 and mario kart wii (all the games I have) result in a black screen and a hanger for me with opengl. (7670)
That also worked in earlier releases. idk what happened, but some "fix" completely screwed the emulator up for me.

My system:
2600K
4870X2 with the newest catalyst
8GB RAM
win 7 64-bit

#4 Updated by greenarrowvigilante over 8 years ago

Tried 7690 now and the issue still isn't fixed. At least now opengl works for me, but the colorbug persists even with opengl.

#5 Updated by greenarrowvigilante over 8 years ago

Ok I rechecked now and the colors are fine till 7623 and get messed up with 7625.
Could someone now please investigate this or is there any more information that you need?

#6 Updated by alforata over 8 years ago

I can confirm the issue, I'm having the same problems with my HD5750 1GB, latest drivers too.

#7 Updated by greenarrowvigilante over 8 years ago

I just tested with 95 and the problem seems to be fixed now.

#8 Updated by DimitriPilot3 over 8 years ago

  • Status changed from New to Duplicate
  • Category set to gfx
  • Issue type set to Bug

"Ok I rechecked now and the colors are fine till 7623 and get messed up with 7625."

The texcache-rewrite branch was merged into trunk/master by r1136b97aa8ea (SVN r7625). After the switch from SVN to GIT, this branch was unmerged (made back into a branch again) because it seems to have caused (many) problems which (AFAIK) haven't been fixed yet. Which is why your problem disappeared after that, since you used a master build

Most likely a texcache-rewrite issue which is yet to be fixed.

Also available in: Atom PDF