Project

General

Profile

Emulator Issues #4703

OGL: Okami broken with OpenGL in r7634

Added by MayImilae about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Changes made to OpenGL in r7634 breaks Okami. Note that DX9 is completely unaffected, and continues to work (Badly, see http://code.google.com/p/dolphin-emu/issues/detail?id=4317)

Start Game Screen
7633 - http://img98.imageshack.us/img98/9389/7633startgamescreen.jpg
7634 - http://img339.imageshack.us/img339/9993/7634startgamescreen.png

Select Save Menu
7633 - http://img812.imageshack.us/img812/5874/7633selectsavemenu.jpg
7634 - http://img37.imageshack.us/img37/4732/7634selectsavemenu.png

Ingame
7633 - http://img838.imageshack.us/img838/2929/7633ingame.jpg
7634 - http://img3.imageshack.us/img3/5663/7634ingame.png

Note that there are some variations, such as rendering partially but unplayable and some areas having a display and not others. For example, both the credit slides just after starting the game and the demo movie are both unaffected. Changing settings has no effect.

Tested revisions
r7626 x64 - Fine
r7631 x64 - Fine
r7632 x64 - Fine
r7633 x64 - Fine
r7634 x64 - Broken
r7637 x64 - Broken
r7661 x64 - Broken
r7667 x64 - Broken
r7670 x86 - Broken (menus worked, but ingame was black)

Game ID: ROWE08
Windows 7 x64
Plain Dump


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by Anonymous about 9 years ago

have you tried with r7673?

#2 Updated by MayImilae about 9 years ago

Well, I don't have the SVN system setup, and it's not on the main site, so I don't know of any way to try it. Wait for it to be put on the main site, or do you have some way for me to test it?

#3 Updated by MayImilae almost 9 years ago

Sorry for the delay guys.

Still broken in r7719.

#4 Updated by Autoran1 over 8 years ago

Confirm this, but the issue should be merged to issue 4635
as a texcache-rewrite issue

#5 Updated by skidau about 8 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF