Project

General

Profile

Emulator Issues #4730

Internal Resolution overruled by window size

Added by oehrgmbh over 8 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The internal resolution setting is behaves rather strange. Apparently, the emulator just uses the current window (or fullscreen) resolution if the window is smaller than the specified internal resolution.
Example: Setting 4x Native with a window size of 640x480, still only results in a 640x480 rendered area. That should not happen. This also makes it impossible to take screenshots of a game higher than the monitors maximal resolution.

History

#1 Updated by glennricster over 8 years ago

Wonderful. Yet another individual that does not know the meaning of the word resolution.

#2 Updated by Baagel.Noogan over 8 years ago

are you saying that if you set the internal resolution to 2560x2112, the window size should be that big? i don't quite understand you

#3 Updated by rukariosake over 8 years ago

I think he's talking about screenshot feature in dolphin.

He was saying that screenshot resolution should be based on internal resolution, not window resolution.

#4 Updated by oehrgmbh over 8 years ago

I made a small mistake: dolphin does render at the specified internal resolution, though only takes a screenshot of the window and not the actual resolution. this should def be changed

#5 Updated by oehrgmbh over 8 years ago

well more than small, but you get my point: screenshot feature should function just like PCSX2 implementation: take a shot of the internal resolution and not of the displayed window. Currently, you get blurry screenshots (window size larger than internal size) or shrunk shots of what is actually being rendered (window size smaller than internal size)

#6 Updated by calc84maniac over 8 years ago

Yeah, if someone wants a screenshot of the displayed window they should just use printScreen

#7 Updated by oehrgmbh over 8 years ago

With a proper screenshot function, we also get rid of black bars in some cases. also no more overlay stats such as FPS will be included in the screenshots either.

is it possible to rename the title of this issue? since my incorrect title is misleading :(

#8 Updated by NeoBrainX almost 8 years ago

  • Status changed from New to Won't fix

Also available in: Atom PDF