Project

General

Profile

Emulator Issues #4772

Health bars in Little King's Story don't display properly

Added by l3illyl3ob about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties:

Little King's Story RO3EXJ

1) What is the expected output? What do you see instead?

The health bars are made up of blue diamonds hovering over your citizen's heads. Instead of the diamonds, I get a solid blue box over each head.

2) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin?

This problem does not occur on r7625. I figured it might be a texcache rewrite issue, but it works on 7625, when it was first implemented. I haven't tried every build thereafter to figure out which specific one it broke at, don't really have the time.

3) What steps will reproduce the problem?

  1. Start a new game
  2. After all the cutscenes are over, walk to a care-free adult and press B on them to recruit them. Their health bars will be replaced with a solid blue block.

4) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar: "R 4779", "R 6403M", "3.0", etc)?

r7690M, r7647. Both 64 bit.

On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.

Windows 7. AMD Phenom X4 945 @ 3.5 GHz, 4GB of RAM, Radeon HD 6870 with Catalyst 11.6.

5) Please provide any additional information below.

Happens on Direct 3D9, Direct 3D11, and OpenGL. I've tried toggling all the settings to no avail.

6) Attachments.

How it looks bugged: http://i.imgur.com/B9own.jpg
How it's supposed to look: http://i.imgur.com/GIYXw.jpg


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by NeoBrainX about 9 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF