Project

General

Profile

Emulator Issues #478

Pikmin 2 not emulated

Added by ekshenman over 11 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Open Dolphin
2. Run Pikmin 2 for GC

What is the expected output? What do you see instead?
Show only Nintendo Logo and all:( I test with JIT and without JIT. Not
working:(

What version of the product are you using? On what operating system?
DolphinWx r1842 (Dual Core Mode), Windows XP SP3, AMD Athlon 64 X2 Dual
Core Processor 4600+, NVIDIA GeForce 6150E, 512 Mb Video Memory, 2Gb RAM

History

#1 Updated by XTra.KrazzY over 11 years ago

Seriously, you are reporting too many issues....

What happens? Does it crash? Hang? what is the Hz counter in the title showing?

#2 Updated by ekshenman over 11 years ago

*I report many issues because I haven't some days Internet.

In Pikmin 2 after showing Nintendo Logo happens nothing but in title showing ~40FPS.
What is this?

#3 Updated by XTra.KrazzY over 11 years ago

Is the openGL window stuck, or the FPS keeps changing?

#4 Updated by lpfaint99 over 11 years ago

Pikmin 2 NTSC works fine for me, I didnt play far, but I can get to the first level
on a new save. r1842 xpsp3 c2d e6550 2.13 2gb ram 8800gt

#5 Updated by thegamefreak0134 over 11 years ago

I've played Pikmin 2 extensively, it lets you beat the first "tutorial" level, but
then crashes when it loads the map to select other levels, unless this was fixed? In
any case, it should be working fine to that point, I didn't notice any other issues.

I will notice that the title screen for Pikmin 2 is very processor and graphics
intensive compared to the logo and menus, so expect a severe performance hit on a
non-optimal system during that.

#6 Updated by 4luC4rD.h3lls1nG over 11 years ago

I can confirm the PAL version doesn't work, it get stucked on the nintendo logo, and
the fps move between 49.5 and 50.5, so it's not that the emu had crashed, it just
doesn't want to go further.

#7 Updated by XTra.KrazzY over 11 years ago

Try r2065 and up and reconfirm please.

#8 Updated by ekshenman over 11 years ago

I try r2068. Nothing more:(

#10 Updated by ekshenman about 11 years ago

I try r3069. Not emulate still :(

#11 Updated by XTra.KrazzY about 11 years ago

  • Status changed from New to Fixed

sounds like it is now.

#12 Updated by gosvald over 10 years ago

i am using opensuse 11.2 and r4883 and this issue with the PAL pikmin 2 is still
occuring with me, any help?

#13 Updated by moogoat over 10 years ago

Use a newer build.

#14 Updated by Nenaptio about 10 years ago

still doesnt work :/

#15 Updated by XTra.KrazzY about 10 years ago

Pikmin 2 works perfectly, tested and verified.

#16 Updated by subatomic202 about 10 years ago

the status clearly shouldn't be fixed.. i have the same problem, no one has suggested anything that works above. why does it say "Fixed?"

#17 Updated by XTra.KrazzY about 10 years ago

because the game can be played?

#18 Updated by yaemi.fevrier over 9 years ago

i recently downloaded pikmin 2 and im using dolphin and after the tutorials i reach to a black screen but i can still see the day 1, the main to characters heads and how many pikmin i have before they die.

#19 Updated by jotapdiez about 9 years ago

Still not working. When I click play, the Nintendo Logo appears and nothing more. I tried about 30 times (or more) with 'play' and 'stop'.
On Windows XP, the same ISO works with after some tries.

Dolphin rev: 7555 (Compiled From sources following http://code.google.com/p/dolphin-emu/wiki/Linux_Build)

My machine:

Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
4gb Ram
Slackware 13.37.0
Geforce 9600GT PCIE (Nvidia Driver version: 260.19.44)

Some ISO details:

PIKMIN2 for GAMECUBE
(GameID) GPVP01
(Country) EUROPE
(FST Size) 90872
(Need some other info about iso?)

Somebody have some hack or specified configuration to solve this issue?

#20 Updated by jotapdiez about 9 years ago

Probably fix (works for me):
The problem (I think) is with audio system because when while the game are not working, I removed audio system and the game started ALWAYS. So, I started the game, in the main menu I save the state, stoped the game, enabled audio and load the state and the sounds works fine and game too.

Hope help (sorry about my english)

#21 Updated by maybeway36 about 9 years ago

Still having this issue, with the Wii version of Pikmin 2. My computer is a Dell Inspiron 15R (http://www.dell.com/us/p/inspiron-15r/pd) running Windows 7 64-bit. Dolphin r7606. I don't think it's possible to disable the audio.

#22 Updated by maybeway36 about 9 years ago

This particular issue was fixed for me by using LLE instead of HLE. (There are still unrelated cutscene issues making the game unplayable for me)

#23 Updated by 357A almost 9 years ago

I'm using r7584 and gc nor wii is working.

#24 Updated by amazing0 over 8 years ago

THANK YOU!

jotapdiez's work around fixed it!

"Probably fix (works for me):
The problem (I think) is with audio system because when while the game are not working, I removed audio system and the game started ALWAYS. So, I started the game, in the main menu I save the state, stoped the game, enabled audio and load the state and the sounds works fine and game too."

i have not played yet..... but i got past the intro screen and im about to test the game!

this will be my first game on dolphen.

i shut off audio.... started game.... it worked... i saved the state.... turned the game off.... turned audio back on... started the game, and loaded my save... it worked!

lets hope the game runs good for me!

thanks again for helping me with my first game on dolphine!

(im a bad spellerrr!)

#25 Updated by pimpachu16 about 7 years ago

it doesn't work for me and im useing dolphin 3.5.win32

#26 Updated by brandsdiervoeders almost 7 years ago

I Use Dolphin 3.5 - 367 On Windows 8 and the thing with the sound work for me!!

Also available in: Atom PDF