Project

General

Profile

Emulator Issues #4780

Zack and Wiki EFB changes the whole screen instead of just the cursor area

Added by keller.g almost 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):
RTZE08

1) What is the expected output? What do you see instead?
In Zack and wiki, you use the wiimote as a "flashlight" to look for items of interest. When not highlighting anything interesting, the flashlight area in a small circle around the wiimote cursor should be blue. When you find something, it turns red.

In release 3.0, setting the EFB to Virtual causes the entire screen to change to blue or red tinged. Changing the setting to Real fixes the issue.

In latest SVN (r7695), both settings cause the entire screen to change to blue or red tinged. Also note that the FPS display changes colors as well.

For the r7695 issue, I suspect this has to do with the changes in r7625, which also messed with EFB for SMNP01. I do not know what causes the Virtual EFB to cause this issue.

Please let me know if I can provide any other helpful information.

2) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin?
(If so, please specify the latest revision that worked.)
3.0 -- issue can be worked around by setting EFB to Real

3) What steps will reproduce the problem?
1. Load Zack and Wiki
2. Start a new game
3. Once the initial dialog is complete and you're told to examine items around you, point the Wiimote at the screen

4) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar: "R 4779", "R 6403M", "3.0", etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.

r7695 and 3.0
Ubuntu 10.04 x64
nVidia GeForce 8800GT (260.19.06)

Note that out of all the above settings, changing the EFB to Virtual or Real is the only thing that affects the issue.

5) Please provide any additional information below.

1x resolution, 4x AA, 4x AF
Per-Pixel Lighting is on
Force Texture Filtering is on
Skip EFB access from CPU is off
EFB Copies is Virtual only
EFB is Virtual or Real
OpenMP/OpenCL are on
Disable Per-Pixel Depth is on

Normal: http://imageshack.us/photo/my-images/691/normalll.png/
Blue: http://imageshack.us/photo/my-images/151/blueg.png/
Red: http://imageshack.us/photo/my-images/4/reden.png/


Related issues

Is duplicate of Emulator - Emulator Issues #4635: TexCache Rewrite issuesWon't fix

History

#1 Updated by NeoBrainX almost 9 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF