Project

General

Profile

Emulator Issues #4852

New SUPER MARIO BROS. Wii doesn't boot on latest rev (3.0-96 x64)

Added by cloud101090 almost 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: New New SUPER MARIO BROS. Wii - "SMNE01"

2) What is the expected output?
The game boot & play normally

What do you see instead?
Black screen with 0 FPS 60 VPS when start booting the game

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
Dolphin 3.0 x64 can boot & play this game normally

4) What steps will reproduce the problem?
1. Just Start the game on latest rev

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar: "R 4779", "R 6403M", "3.0", etc)?
Dolphin 3.0-96 x64 SSE3 Unpatched

Forum dolphin link :
http://forums.dolphin-emulator.com/showthread.php?tid=18884

On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
- Win 7 x64
- Phenom II X4 955 BE & AMD HD 5850, 4 GB RAM
- Latest Drivers Updated

6) Please provide any additional information below.
Something make this game broken between Official 3.0 release and latest rev. Sorry can't pinpoint the exact rev that causing this problem.

History

#1 Updated by NeoBrainX almost 9 years ago

These builds aren't supported, try with a non-ICC, non-SSE3 build.

#2 Updated by cloud101090 almost 9 years ago

How about ExtremeDude2 builds?
http://forums.dolphin-emulator.com/showthread.php?tid=16466

I can't compile it myself because my internet speed is suck. Mamario's build isn't update too.

I will post the result later.

#3 Updated by cloud101090 almost 9 years ago

OK, tested with ExtremeDude2 build, 3.0-95 64-bit, same result.
Black screen with 0 FPS 60 VPS.
The others game boot normally.

#4 Updated by NeoBrainX almost 9 years ago

Works fine here and there have been almost no commits since 3.0 which would make that game blackscreen.
Probably something with your config (game specific config etc).

#5 Updated by wespipes69 almost 9 years ago

Game works fine. I've been playing for days on the latest builds. This is only an issue with your setup.

#6 Updated by cloud101090 almost 9 years ago

agghhhh. after re-checked again, I can't play this game on any rev (the other games works properly). And after read your comment, I'm pretty sure that my ISO was corrupted somehow.

Re-dumping again & this game can boot normally now. Sorry for invalid issue NeoBrain -_-. And thanks for your fast response.

#7 Updated by Anonymous almost 9 years ago

  • Status changed from New to Invalid

#8 Updated by smallthingsmatters over 8 years ago

actually its dolphin problem
it doesn't boot from perfectly working dump 65xx revisions boot ,74xx+ doesn't fps is 0

#9 Updated by smallthingsmatters over 8 years ago

typo it does boot and works properly on 65xx and doesn't on 74xx

#10 Updated by smallthingsmatters over 8 years ago

no,can't make it to boot.
howto:
-download fresh clean build from dolphin page
-just setup basics for dolphin to load game
-start the game
result:hang on startup fps 0,no response.

#11 Updated by tommyhl2.SS over 8 years ago

Stop downloading crappy game torrents and rip the game yourself. The game plays fine with Dolphin.

#12 Updated by smallthingsmatters over 8 years ago

here is proof of how it boots properly in 6505 my old one
http://i39.tinypic.com/202yv5.jpg
after that tried many revisions ,neither boots

#13 Updated by smallthingsmatters over 8 years ago

Very smart comment to ditch me.
In matter of fact i own NSMB from the day it got released and its dumped to my hdd my sister played for long time.and after updating dolphin it doesnt any more.

#14 Updated by danialhorton over 8 years ago

wfm

#15 Updated by WesaMcDaniel over 8 years ago

Do you have two wiimotes connected? Try one. I ran into that before. Other than that, no clue. Take this to the forums. This is not the place for help on some weird obscure issue. Dolphin obviously boots the game properly for everyone, including me. It's the iso and some strange setting/config problem.

#16 Updated by smallthingsmatters over 8 years ago

I just spent 2 hours dumping iso again
And what everyone failed to mention is that in 2010 when game was released it had to be patched in order to work on dolphin
http://forums.dolphin-emulator.com/showthread.php?tid=5415&highlight=[Wii]
All this time my sis played on old 6505 revision with patched iso ,and now since dolphin got "fixed" it doesn't boot any more on new revisions due that patching process.
It would be nice if someone could actually edit that topic to notify people to redump and not to patch their isos!It would be nice

#17 Updated by parlane over 8 years ago

Are you NTSC or Pal?

#18 Updated by smallthingsmatters over 8 years ago

pal

#19 Updated by parlane over 8 years ago

It already says it doesn't need doing on Pal ?

#20 Updated by parlane over 8 years ago

And that last post was updated in 2009?!

#21 Updated by smallthingsmatters over 8 years ago

parlane what is your problem?you can't read or something?i said i patched it the day i obtained it.Learn to read all posts not just last post ,m?
Anyway problem is solved.

#22 Updated by parlane over 8 years ago

"And what everyone failed to mention is that in 2010 when game was released it had to be patched in order to work on dolphin"

That is what you said. The forum post saying not to patch for PAL versions was last updated in 2009.

Also available in: Atom PDF