Project

General

Profile

Emulator Issues #4922

TMNT: Fog is not rendered properly in all scenes leading to unplayable sections

Added by wespipes69 about 8 years ago. Updated almost 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
PPC
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-6259

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):
TMNT GYRE41

2) What is the expected output? What do you see instead?
Correct and consistant fog emulation. On some levels it's fine (rendered properly) but on other levels it makes the game unplayable.

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
Probably always been an issue.

4) What steps will reproduce the problem?
1. Launch game with fog enabled
2. Observe title screen gfx (some buildings are solid green)
3. Also, attempt to play level 6

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar: "R 4779", "R 6403M", "3.0", etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
Dolphin 3.0 159, Win 7 x64, GF460gt w/latest drivers.

Screenshot:
http://imageshack.us/photo/my-images/207/unledlj.png/

GYRE41.dff (4.58 MB) GYRE41.dff seapancake, 06/23/2016 03:13 PM
GYRE41-4.png (320 KB) GYRE41-4.png Level 6 is unplayable seapancake, 06/23/2016 03:13 PM
GYRE41-1.png (1.86 MB) GYRE41-1.png Fog around the temple is fine seapancake, 06/23/2016 03:13 PM
5468
5469

History

#2 Updated by tommyhl2.SS over 7 years ago

List the full name of the Turtle game, it's not just TMNT.

#3 Updated by parlane over 7 years ago

And attach a dff please.

#4 Updated by wespipes69 over 7 years ago

@tommy
What are you talking about? It's TMNT everywhere that I see. That's the full name of the game....you must be thinking of something else. What do you think it is?

parlane
Here's ya go!
http://d01.megashares.com/dl/3zKaABL/tmnt.dff

#5 Updated by tommyhl2.SS over 7 years ago

Confusion is that this is my TMNT game http://i.imgur.com/8sXE0.jpg which is not your TMNT game. The game ID should be enough but next time just add some more info if possible. There are like 10 TMNT games. :p

#6 Updated by sktsqrl over 7 years ago

#8 Updated by NeoBrainX over 7 years ago

Download link broken, please upload the dff file somewhere else where it doesn't get deleted after less than 3 months..

#9 Updated by wespipes69 over 7 years ago

It's actual still there - you have to copy/paste the link into address bar. Doesn't work for some reason just clicking on it.

Anyway, I also put it on Mediafire here: http://www.mediafire.com/?mx7w110e1q5u8mw

#10 Updated by NeoBrainX over 7 years ago

  • Status changed from New to Work started

Most likely due to wrong magic numbers in fog calculation.
This game uses exp2-distributed fog intensity, so scaling the exponent by 8.f instead of e.g. 1.f is very noticeable. Using 1.f instead makes the fog look less extreme.

Guess I'll have to carry out some tests on real hw to find the optimal value.

#11 Updated by Billiard26 almost 7 years ago

  • Issue type set to Bug
  • Category set to gfx

#12 Updated by NeoBrainX almost 7 years ago

For reference, my previous comment was likely wrong. the scaling exponent does seem to be fine.

#14 Updated by NeoBrainX over 6 years ago

  • Status changed from Work started to Accepted
  • Category changed from gfx to ppc

Likely not a GPU emulation bug.

The fog parameters are "infinity" and native dff player shows a similar issue.

#15 Updated by NeoBrainX about 6 years ago

Please provide a save file for the game and steps to reproduce the issue with minimal effort and without assuming I've ever seen the game in action. I'm running the game at 10 FPS and really don't want to play through the first few levels just to see I've done something incorrectly.

#16 Updated by wespipes69 about 6 years ago

https://skydrive.live.com/redir?resid=BB6DBB7514C6BD0F!356

Simply load up on save on this GC mem card, and select level 6.

#17 Updated by NeoBrainX about 6 years ago

Reproduced the issue, happens even in Interpreter mode. Still not quite sure what to do about this :|

#18 Updated by wespipes69 about 6 years ago

Wonder why disabling fog fixes it...

#19 Updated by NeoBrainX about 6 years ago

The fog values are invalid. The fog strength is set to infinity, so it's no surprise that you can't see anything but green :p

#20 Updated by NeoBrainX about 6 years ago

Revision c02ca4f1ece1 in the ppc_fp branch (non-IEEE mode emulation) seems to fix this issue. It seems like the branch also makes the game reboot when trying to load the memory card, but you still use state saves to get ingame and it'll render fine.

#21 Updated by flacs about 6 years ago

  • Status changed from Accepted to Fixed
  • Operating system N/A added

The ppc_fp branch was merged into master: b863e40677710f2d53cae8aedfe450b4215562d3.

#22 Updated by flacs over 5 years ago

  • Status changed from Fixed to Accepted

It's still broken in both Interpreter and Jit64 even though Star Fox works correctly now (issue 182).

Workaround: use "JITIL Recompiler"

#23 Updated by JMC4789 about 5 years ago

JITIL isn't a work-around for this any longer, and I can't find a build where it was a work-around.

#25 Updated by ZephyrSurfer about 5 years ago

Can we just clamp the fog to some arbitrary value? Maybe someone could make a hwtest to fix fog issues. Surely any clamped value is better than having full fog.

Is this that what breaks Legacy of Kain as well?

#26 Updated by flacs about 5 years ago

Clamping fog would be a hack and there already is one that just disables fog completely.

#27 Updated by ZephyrSurfer about 5 years ago

It hasn't been fixed since 2011, scratch that It's never worked.

I think clamping makes sense. Some audio issues were fixed by clamping it's volume.
This would be similar in clamping fog volume as it were.

It's got to be an improvement, right? yes

#28 Updated by JMC4789 about 5 years ago

No. Clamping volume was the accurate behavior to console. Clamping fog doen't appear to be accurate at all.

#29 Updated by seapancake over 3 years ago

5468
5469
  • Tested in 4.0-9503
  • First screenshot is from the first level, fog effects render correctly
  • Loading level 6 from save entire screen is green, the building in the background of title screen has the same issue
  • Occurs in 4.0.2 D3D/OGL and software, tweaked settings but made no difference
  • FIFO log attached

#30 Updated by JMC4789 almost 2 years ago

I know it's been a while... but...

Fixed in PR6348 - https://github.com/dolphin-emu/dolphin/pull/6348

#31 Updated by JosJuice almost 2 years ago

  • Status changed from Accepted to Fix pending

#33 Updated by JosJuice almost 2 years ago

  • Fixed in set to 5.0-6259
  • Status changed from Fix pending to Fixed

Also available in: Atom PDF