Project

General

Profile

Emulator Issues #4966

Sims Blur Censor slow due to EFB Poke

Added by kodiacktech over 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID: G4ZE69 - The Sims 2; G4ME69 - The Sims: Bustin' Out; GUBE69 - The Urbz: Sims in the City; Others

2) What is the expected output? What do you see instead?
The censor used to censor nudity in the Sims titles incurs a significant hit to performance and causes the title to run slowly while the blur effect is onscreen. Panning the camera off to the side returns performance to expected levels.

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin?
As far as I know, this has always been an issue and doesn't seem to have been caused by one specific revision.

4) What steps will reproduce the problem?
1. Load up any Sims title
2. Do an action to bring the blur effect up (e.g. make them use the bathroom or a shower)
3. Keep the panned over the blur effect

5) What version of dolphin are you using?
Dolphin 3.0-199-dirty (64-bit)

On what operating system, drivers, and hardware?
Windows 7 x64, Core i7 920, 12 GB DDR3 memory, Radeon 5870+5970 Tri-Crossfire (Catalyst 11.10 & latest application profiles)


Related issues

Has duplicate Emulator - Emulator Issues #2612: Slowdown in Zelda Four Swords AdventuresDuplicate

History

#1 Updated by skidau almost 8 years ago

The reason why it is slow is because EFB Poke is being used. Using the "Skip EFB Access from CPU" will speed up the game (and remove the censor).

#2 Updated by NeoBrainX almost 8 years ago

  • Status changed from New to Invalid

#3 Updated by skidau almost 8 years ago

issue 2612 has been merged into this issue.

Also available in: Atom PDF