Project

General

Profile

Emulator Issues #5045

Bad CPU core count detection - only affects LTtC / OpenMP

Added by vojin.djekic over 8 years ago.

Status:
Won't fix
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[The following is a template to help you fill out a more informative
report]

Note:
Many games do not run yet, or have known problems. Please do not report
those games without giving any more information. That means reports like
"Game XYZ crashes" are not helpful. Instead try to include as much debug
information as possible. Also try to search the issue tracker for similar
bugs before creating a new issue.

--------------------------------------

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc): Any game

2) What is the expected output? What do you see instead?
im using i3 sandy cpu, 2c/4t

expected: 4 "cores" (2 cores, 4 threads)
instead : 8 "cores" (4 cores, 8 threads), dolphin detects threads as cores + hyperthreading...

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
Don't know.

4) What steps will reproduce the problem?
1.run any game with i3 2310m cpu (or possibly any cpu with hyperthreading)
2.
3.

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.

Dolphin 3.0 - 216 x64
i3 2310m

6) Please provide any additional information below.
Don't know if this issue affects performance, but i3 @ 2100Mhz
is a lot slower than C2D @ 2333Mhz, Resident evil remake and zero run like crap on i3 sandy.

7) Attachments. IMPORTANT! We have a limited storage quota on
GoogleCode, so please use a 3rd party host for screenshots or any other
files (http://min.us/ for example).

Screenshot:
http://i40.tinypic.com/b68pas.jpg

History

#1 Updated by vlakipn over 8 years ago

It looks like it shows factory clock of your CPU. For example i got i5 2500k running at 4GHz and in dolphin it shows factory 3.3GHz.

#2 Updated by delroth over 8 years ago

Works fine with an i7-920 (4 cores, 8 threads) so it's not directly linked to HT.

Can someone reproduce this issue? Also, on which OS was this bug happening?

#3 Updated by vojin.djekic over 8 years ago

Windows 7 Ultimate x64...

#4 Updated by vojin.djekic over 8 years ago

I did some tests.

C2D E5300 @ 2100MHz, 9800GT, 4GB of ram
vs
i3 2310m @ 2100MHz, GT540m, 4GB of ram
all graphical settings were set to lowest and game was run at native resolution to avoid any gpu bottleneck!

Resident Evil Archives (remake)

Single core mode - sandy wins, 5-15 fps advantage (as expected)
Dual core mode - core2 wins, 1-3 fps advantage (???)

Is it possible that dolphin uses two threads from a single core in dual core mode when using i3 cpu?
I don't think there are any problems with older i3 mobile cpus, i ran the same game some time ago, and as far as i remember performance was very good and there were no any core/thread problems.

#5 Updated by Anonymous over 8 years ago

I also see this, I've got an i5-750 and it says:
8 Cores, 2 logical threads per physical core
And that HTT is supported

The i5-750 is a quadcore, with no hyperthreading.

#6 Updated by Anonymous over 8 years ago

Also win7 x64 sp1

#7 Updated by school.player over 8 years ago

@vojin: It is widely known that Hyperthreading has no real value and should ALWAYS be turned off, particularly for emulation.

I, for one, can vouch to this issue.

Dolphin r7461 x64 (Dolphin main site buildbot)
Windows 7 Home Premium x64
Core i3 540 @ Stock
Hyperthreading DISABLED (which makes this all the more strange)

#8 Updated by vojin.djekic over 8 years ago

Thank you. However, i can't turn off Hyperthreading on my laptop, options in bios are very, very limited.

I disagree with you about HT. Dolphin can't use more than two cores, so HT makes no difference, but there are certainly some cases where HT can be useful.

#9 Updated by PianoGamer about 8 years ago

Very wrong core detection on my Dell XPS 15z with i7-2640M. It's dual core with 4 logical threads, but Dolphin says 4 cores with 8 logical threads, and will only use 50% CPU in dual core mode (25% in single core mode).

#10 Updated by crazyigor about 8 years ago

Same here, have an Intel Core i3 2100 ( 2 Cores with Hyperthreading )
I get aprox 30% more FPS by deactivating Hyperthreading in the BIOS. And it stutters no more in the games ...

But its really annoying to switch allways the BIOS-Setting, because i need it for some other apps. Looking forward for a patch / workaround. :)

#11 Updated by crazyigor about 8 years ago

Is this ticket at process? I mean, theres no update since December 2011 ( Status: OnHold ). It's really annoying. Please update to more priority.

#12 Updated by delroth about 8 years ago

No. The only way you have to make this issue more high-priority is by submitting a working patch.

#13 Updated by YuriShish over 7 years ago

Intel Core i5 3570k, dolphin-emu 3.0-801 detects HT (8 cores) while it isn't supported.
Games speed is 100% but CPU loads only 50% per core or less (top shows cpu loading ~170-190%).

#14 Updated by diegojp955 over 7 years ago

Any update???

#15 Updated by Billiard26 over 7 years ago

  • Priority set to Low
  • Operating system N/A added

Do we care how many cores Dolphin thinks a CPU has?
Isn't this information only used for "lock threads to cores"? (a stupid option)

#16 Updated by vojin.djekic over 7 years ago

We do, performance is terrible on dual core CPUs with hyperthreading. It's probably using threads from the same core. Enable/disable Dual Core option in Dolphin makes no difference in performance.

#17 Updated by Billiard26 over 7 years ago

@ vojin.djekic
Dolphin appears to only use the "number of cores" value when LTtC or OpenMP are enabled. (two features which some of us want removed anyways)
(Dolphin's knowledge of the number of cores is not as important as you seem to think.)

#18 Updated by vojin.djekic over 7 years ago

It also appears that Dolphin is unable to use the second core when running on dual core cpu with HT. Basic stuff isn't working, don't care about LTtC or OpenMP right now.

#19 Updated by Billiard26 over 7 years ago

  • Status changed from New to Invalid

Try reading what I type at you, vojin.djekic..

#20 Updated by Billiard26 over 7 years ago

  • Status changed from Invalid to Questionable

oops, didn't mean to do that :p

#21 Updated by vojin.djekic over 7 years ago

bravo

#22 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#23 Updated by haddockd1 over 7 years ago

I can confirm this is happening. I get the issue in 3.0 and 3.5 64 bit. I am using Win 7 x64 SP1 on an i5-2500K (which has no HyperThreading). Link to the screenie here:
http://s3.postimage.org/3xwyu8zir/Untitled.png

I would be happy to give any more details needed.
Adding more***

I do not mess with OpenMP and do not know what LTtC is so I cannot speak for those :)

#24 Updated by Billiard26 over 7 years ago

  • Status changed from Questionable to Won't fix

This issue is made irrelevant by r206fdde9332859b53a22d415d3db304d997e8540.

#25 Updated by haddockd1 over 7 years ago

Awesome. Thanks!

#26 Updated by white.phoenix over 7 years ago

This still needs to be fixed instead of just hiding the core count from the OSD, especially if OpenMP is getting it's core count wrong.

#27 Updated by Billiard26 over 7 years ago

@ white.phoenix
OpenMP gets the count elsewhere now.

Also available in: Atom PDF