Project

General

Profile

Emulator Issues #5080

nunchuck lag - skyward sword

Added by kankatsu over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) The Legend of Zelda Skyward Sword - SOUP01

2) Im using a Memorex wiimote+ with a real branded nunchuck. while playing the game the nunchucks joystick will appear too lag, either becoming unresponsive for 1-2 seconds, or having an action stick (continuing to move after letting go) for afew seconds. The issue is randomly constant through entire play time, meaning that there are times it runs perfect and there are also a same amount of times it will have these lag spikes.

3) the only other revisions i have tried this on was 7719, which appeared to still have the issue.

4) there are no steps that will cause this really, other then just starting the game and playing.

5) running on dolphin 3.0-228
hardware/os
-Windows 7 64bit
-Phenom II X4 965
-ATI HD 6950 (driver - 8.892.0.0
-8gb ram
-8ware mini bluetooth dongle (V2.0)
-Pulse peripherals sencor bar
-memorex controller plus
-Nintendo branded nunchuck

6) the game runs perfectly fine, i have no graphical issues or crashes. the only issue that there really appears to be is controls. while monitoring the strength of the bluetooth connection while playing it remains between "good and strong" according too bluesoleil.

Im really loving the game, damn shame the wii outputs like turd on large HD televisions, so I really hope this can be fixed. :)

History

#1 Updated by kankatsu over 9 years ago

It looked like the option was already ticked (was filled in with a blue square, turned into a tick after disabling/re-enabling it). but, after doing so, the issue appear too be less common, just tried for the last 15 minutes and the amount of times and length of the "stickiness" has decreased. the problem is definatly still there, however does not seem to be as bad.

#2 Updated by BentZero over 9 years ago

I'm also having this problem as well as the pointer not working correctly. The pointer is jumping all over the place when I go into first person mode.

#3 Updated by BentZero over 9 years ago

Reduced pointer issue by turning sensitivity way down.

#4 Updated by school.player over 9 years ago

If I'm not mistaken, you're full of bullshit because Skyward Sword doesn't use the sensor bar, so sensitivity would have no effect.

#5 Updated by danialhorton over 9 years ago

"If I'm not mistaken, you're full of bullshit because Skyward Sword doesn't use the sensor bar, so sensitivity would have no effect."

wow, could have fooled me, what with the cursor not fucking working when the sensor bar was turned away from the wiimote's direction.

#6 Updated by kamiyo over 9 years ago

Despite school.p's language, I think he's right, because Skyward relies solely on the wii motion plus to do the motion sensing. I have not seen any issues (I've been playing it on my dolphin) with either nunchuck or pointer, but did you check on the wiki for Skyward that you have to NOT check skip EFB access to CPU? Or else you won't be able to aim in first person mode.

#7 Updated by d.winkler over 9 years ago

Skyward is using the Sensobar to recalibirate the Wiimote...
if no sensorbar is visible the nunchuck goes crazy...

just make sure if the sensobar is visible

#8 Updated by parlane about 9 years ago

  • Status changed from Work started to Invalid

No reply from original poster of issue.

Also available in: Atom PDF