Project

General

Profile

Emulator Issues #5084

Skyward sword freeze

Added by kardifas over 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[The following is a template to help you fill out a more informative
report]

Note:
Many games do not run yet, or have known problems. Please do not report
those games without giving any more information. That means reports like
"Game XYZ crashes" are not helpful. Instead try to include as much debug
information as possible. Also try to search the issue tracker for similar
bugs before creating a new issue.

--------------------------------------

1) Game Name and ID
The legend of Zelda : Skyward Sword
"SOUP01" PAL

2) Issue: In ancient cistern, when you try to unlock the door, the lock falls a little and then freezes.

5) Dolphin version:
r7719 (x32)
Windows XP
I'm using emulated motion+

6) Please provide any additional information below.
The game works perfectly, except for inaccuracy of sinshot, beetle, etc.

7) Attachments. IMPORTANT! We have a limited storage quota on
http://forums.dolphin-emulator.com/attachment.php?aid=7080

History

#1 Updated by Nintendo.Wii.DS over 9 years ago

I don't have this issue on 3.0-234 (emulated W+).

#2 Updated by Sonicadvance1 over 9 years ago

  • Status changed from New to Invalid

Using outdated version. check with latest.

#3 Updated by kardifas over 9 years ago

tried with 3.0-235. Makes no difference

#4 Updated by Sonicadvance1 over 9 years ago

  • Status changed from Invalid to New

#5 Updated by NeoBrainX over 9 years ago

Try deleting the contents of User/ShaderCache/.

Try redumping the game.

#6 Updated by kardifas over 9 years ago

deleting doesn't help. As for redumping... i don't know how to do that.

#7 Updated by school.player over 9 years ago

If you were not a dirty pirate, you would know EXACTLY how to do that.

#8 Updated by kardifas over 9 years ago

Yeah, yeah... Anyway, problem solved.

#9 Updated by rodrigomartinglez over 9 years ago

Hey guys, I have the same freezing problem, how did you fix it??

#10 Updated by parlane over 9 years ago

  • Status changed from New to Invalid

I assume he found a new iso magically after redumping his legitimate copy of skyward sword.

#11 Updated by danialhorton over 9 years ago

there is a known bad SOUP01 dump floating around.

#12 Updated by parlane over 9 years ago

Aw someone is being nice.

#13 Updated by danialhorton over 9 years ago

moral to the story, use your own.

#14 Updated by kardifas over 9 years ago

As i remember, i founded solution in forum - skip "enable dual core" and "iddle skipping", get through the door and tick them back.

#15 Updated by ulaoulao about 9 years ago

That fix does not work. "enable dual core" and "iddle skipping" both unchecked and still wont let me move after the door is open.

#16 Updated by ulaoulao about 9 years ago

my ID:SOUE01 ( Tried a re-rip )I wonder how he fixed this?

#17 Updated by ulaoulao about 9 years ago

I just want to add more to this in the event it will help to fix it. Please dont take this as nagging ;)

once I open the gate everything about the game works but the controls. Insolently the wii menu button works? If I save state here and reload I get the same thing ( my thinking was the controls were messed us ). The game even goes through the calibration ( controls work )but once in to game play its back to no control. I'm trying a few check boxes to see if anything lets me by but no luck so far.

#18 Updated by ulaoulao about 9 years ago

Wow I found the post this guy was referring to. I may have to use an older version of dolphin not sure. Here is the link he was talking about.
http://forums.dolphin-emulator.com/showthread.php?tid=19897&pid=198438
I have tested dx9, 11 and OPGL. So that fix is out.

Ok I found another thread
http://forums.dolphin-emulator.com/showthread.php?tid=19897&page=55
I love how they tell you what revision it was. This confirms its a bug. I'm sure certain revisions dont discriminate against dumps ;)

If I find a revision that works I will post it.

#19 Updated by ulaoulao about 9 years ago

Ok revision r7608 did it for me. I'm not sure if it was the fact I had all new clean folders ( new install ) or the rev r7xxx. Email me if you have questions.

#20 Updated by ulaoulao about 9 years ago

Some one emailed me:

"could you please send me your dolphin revision? cause i've downloaded the r7608 and for some reason i cant add the motion+ files whitout needing to change the dolphin.exe (which changes to 3.0- something) or send me the save file after the door"

I dont have that version any longer or a save state sorry. Though, there was nothing fancy about that version I had, you just need to try an old one till it lets you though.

#21 Updated by miib over 6 years ago

hi all... i have the same problem...can anyone help me? i try get a new iso file(but not sure is the correct iso)... and download the other version of dolphin... but new downloaded dolphin not support the old save file... do i have to start from the beginning?

#22 Updated by pauldacheez over 6 years ago

Newer Dolphin should support in-game saves perfectly fine. Save states won't work, so if you've been using those you should make a proper in-game save first. If you've been using in-game saves the whole time, you just need to move your saves to the right folder – Dolphin keeps all its data in %AppData% these days, so just move everything from the "User" folder in your ancient Dolphin to the right folder in %AppData%. If you can't find that folder, I can't help ya, I haven't actively used Windows in years.

#23 Updated by pauldacheez over 6 years ago

Anyway, if you have further questions, go straight to the forums. This issue tracker isn't here for user support, especially if you're not reporting an actual bug on a current version of Dolphin.

https://forums.dolphin-emu.org/

Also available in: Atom PDF