Project

General

Profile

Emulator Issues #5106

Crackling audio from wiimote speaker with LLE

Added by giaga7 over 9 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID:
I tried wii party (SUPP01) , super mario galaxy 1 (RMGP01) & 2 (SB4P01), wii sports (RSPP01)...

2) What is the expected output? What do you see instead?
The sound from wiimote should be clean and understandable, instead it's annoying, dirty and with a strange (metallic) background sound

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.

No... for me at least, audio ihas never been good!

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.

I'm using dolphin 3.0-305 x64 dirty by Lectrode, but I've tried with dolphin 3.0-307 x64 by mamario.

I'm on Windows 7 64 bit, i5 2500k, nvidia gtx 570 with 290.53 drivers, 8gb of RAM

6) Please provide any additional information below.

I'm using a original wiimote along with another not original one... The speaker's sound is horrible, even with speaker volume at min.
I'm using LLE DSP recompiler with Xaudio2 audio backend and 48000 Hz.
Enabled only audio DTK and audio throttle.

I'm very happy that speaker is working, but it's really unusable!:(

History

#1 Updated by William79371 over 9 years ago

Same here!

#2 Updated by bdr9 over 9 years ago

For me, it's horrible with both HLE and LLE.

#3 Updated by giaga7 over 9 years ago

For me HLE doesn't work!! if I set Hle instead oh LLE speaker doesn't work! Actually there's an issue about this http://code.google.com/p/dolphin-emu/issues/detail?id=4210&q=speaker

Anyway I noticed a lag when there are too many sounds coming from speaker... and sound is so crackling and annoying that sometime I've to deactivate it!!

#4 Updated by skidau over 9 years ago

  • Status changed from New to Won't fix

This is not fixable because the timing in Windows is not granular enough.

#5 Updated by giaga7 over 9 years ago

And so, speaker's sounds will never be fine?, but the issue occur in windows only or in mac and linux too? sorry for the dumb question... I started this year programming and I just want to learn as much as I can!

Also available in: Atom PDF