Project

General

Profile

Emulator Issues #5107

[Suggestion]Gamecube controller and classic Wii.

Added by willianholtz1 over 9 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
UI
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

It would be possible to make the GameCube controller is not recognized as classics of the wii controls are enabled? Many times it is annoying to have to keep changing the control, or even disabling as the game, and P1 is sometimes the wii classic and P2 is the GameCube controller, thus completely changing the buttons and how to play.

If the user chooses to play with the gamecube control, just disable the wii classic controller.

History

#1 Updated by DimitriPilot3 over 9 years ago

If I want the GameCube controller to have priority over Wiimote controls, I would just go to the Wiimote config dialog, and set the "Wiimote Source" to "None" (instead of "Emulated Wiimote" or whatever else). I consider this rather simple to do [1 + 2X clicks for X Wiimotes to disable], and this should work well as long as ALL players (either one player, or multiple players) decide to use GameCube controllers.

In the (unlikely, especially when this isn't supported through NetPlay yet) case that someone wants to use Wiimote controls instead, I would open the Dolphin Configuration dialog, open the "Gamecube" tab, and set all ports to . A little harder to do [2 + 2X for X controllers to disable] since GCPad doesn't allow you to modify the enabled/disabled flag directly.

If players want to mix Wiimote controls and GameCube controllers in a multiplayer game, (but only if the order of connection REALLY matters) to make sure that Wiimotes are connected in last position, maybe you should just disconnect and reconnect the Wiimotes with ALT+F5/+F6/F7/+F8? or disable and re-enable GC controllers?...

#2 Updated by DimitriPilot3 over 9 years ago

  • Category changed from ui to controls

Basically, options to add (just quickly-thought ideas that come in mind when reading an enhancement issue like this, not pretending that they're needed and/or high priority and/or worth the work needed :/) that may reduce the amount of clicks needed:

  • for Wiimotes: A "disable" flag (checkable box in the initial Wiimote config dialog?), which would prevent the Wiimote from automatically connecting while booting Wii games/apps, while still allowing it to be connected manually with "Alt+Fx", without having to change the Wiimote Source from None to Emulated/Real/Hybrid. Maybe as a replacement of the "None" source type?

  • for GC controllers: Ability to disable/enable GC controllers with Alt+F5/F6/F7/F8 (in GC games ONLY)? Ability to do the same from within the GCPad configuration dialog? ...

#3 Updated by school.player over 9 years ago

How about you just use Alt+F5 whenever you don't want the emu to see a wiimote?

#4 Updated by willianholtz1 over 9 years ago

What I mean is that the wii does not necessarily need to use the GC to control because we can set up the wii classic.

sucks to be changing the controls: for example DBZ: B3 it runs with both GC and Wii classic control, but as always let the two linked both Wii and GC, it would be ideal to recognize only the Wii, if you wanted to play with the GC i disabled the wii. But this does not happen, but if the two are connected randomized controls it just like what he sees putting the first!

That is a priority to put the wii controls, if it is not possible but there emulates the controls of the GC.

#5 Updated by Billiard26 over 9 years ago

  • Status changed from New to Won't fix

Set wiimote input sources to "None".
Set controller ports to "".

I don't see what the issue is.

Certain games make use of both GC controllers and wiimotes simultaneously.
We can not automatically disable wiimotes for you if you are using GC controllers.

Also available in: Atom PDF