Project

General

Profile

Emulator Issues #5114

Fluidity wiiware game crash and can't get ingame

Added by giaga7 over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):

WFLE01 Fluidity \ Hydroventure

2) What is the expected output? What do you see instead?
I should be able to play the game, but the emu crash before I can get ingame and play

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.

Yes it worked, I've to test some revs...

4) What steps will reproduce the problem?

  1. Start the game
  2. press 2 to "open the book"
  3. press 2 to go in the selected world
  4. Crash before it's possible to play, it seem that the crash occur precisely when the water should appear

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.

I'm using 3.0-363 INTEL AVX +DCP x64, on windows 7 x64, nvidia gtx 570 last drivers, intel i5 2500k

6) Please provide any additional information below.

I tried, with jit, jitl, dx9, dx11, opengl, safe texture cache on max accuracy and max performance, with efb to ram and to texture.


Related issues

Has duplicate Emulator - Emulator Issues #5146: TV Show King 2 - crash on start upDuplicate

History

#1 Updated by giaga7 over 9 years ago

I obtained errors only once, I could not save all errors, first appeared a windows with some informations (that I could not save) and than this list of errors:

BackPatch : currently only supporting reads.

Attempted to write 03a63849
Attempted to write 03a6384d
Attempted to write 03a63859
Attempted to write 03a63851
Attempted to write 03a63855
Attempted to write 03a6385d
Attempted to write 03a63831
Attempted to write 03a63839
Attempted to write 03a63835
Attempted to write 03a6383d
Attempted to write 03a63829

Attempted to write 03a6382d

#2 Updated by skidau over 9 years ago

Broken by r4c3a799f08f6f3b6a230987c3e0a1e984cf3a565

#3 Updated by skidau over 9 years ago

issue 5146 has been merged into this issue.

#4 Updated by giaga7 about 9 years ago

So ia it possible to fix?:P I noticed that other games (in particular wiiware games) have been broken... lost winds 1 & 2, and fluidity and now tv show king party 2...

#5 Updated by skidau about 9 years ago

Yes, it is possible when I have some time to look into it.

#6 Updated by skidau about 9 years ago

  • Status changed from New to Fixed

This issue was closed by revision ea2e0e906335.

Also available in: Atom PDF