Project

General

Profile

Emulator Issues #5123

Phantasy Star Online Episodes 1&2 menu is partially offscreen

Added by leftblankonpurpose over 9 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):
Phantasy Star Online Episodes 1&2
GPOE8P

2) What is the expected output? What do you see instead?
Pressing start to open menu shifts screen to top right corner. Issue occurs on planet, does not occur on base

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
Issue has always occurred across multiple versions.

4) What steps will reproduce the problem?
1. Start the game.
2. Press start to open menu on base.
3. Teleport down to planet
4. Open menu, notice that top and right side of menu is off screen.

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
32 bit linux. Dolphin 3.0-368
Nvidia driver version 285.05.09-1

6) Please provide any additional information below.
http://www.youtube.com/watch?v=U_2sYZ5Lk_k
Video shows issue about a minute in

History

#1 Updated by leftblankonpurpose over 9 years ago

Video link is wrong. Correct link follows.
http://www.youtube.com/watch?v=O0o5GhSaeuU

#2 Updated by Billiard26 over 8 years ago

  • Status changed from New to Questionable
  • Issue type set to Bug
  • Category set to gfx

Is this issue still present in Dolphin 3.5?

#3 Updated by MrRagston over 7 years ago

Still dealing with this as well

#4 Updated by JMC4789 over 7 years ago

Please upload a savefile or some kind of media to help with reproducing/testing this.

#5 Updated by devidra1991 over 7 years ago

JMC4789 can you tell me which kind of Media you need?

I downloaded Dolphin 4 and 3.5 both the same, I got also the Problem

If you open the Menu ( Start / Z Button ) to Equip Items, set youre Technique look youre Status etc. the Screen goes Up and oyu have a big black bar on the bottom

#6 Updated by JMC4789 over 7 years ago

Okay, thank you that should be enough information for me to reproduce. I will check it out.

Cheers

#7 Updated by JMC4789 over 7 years ago

  • Status changed from Questionable to Invalid

You're using the widescreen hack. Come on man.

#8 Updated by devidra1991 over 7 years ago

Can you tell me how to deactivate? I only downloaded Dolphin 4 so I didnt change anything

#9 Updated by devidra1991 over 7 years ago

Ok, i changed the backend of the Graphic.. From Direct9 to OpenGL and work fine now, bye

#10 Updated by JMC4789 about 7 years ago

  • Status changed from Invalid to Duplicate

Moving to duplicate

#11 Updated by tueidj about 7 years ago

This isn't related to the widescreen hack, the display looks very different (even more buggy due to incorrect 2D element placement) with it on. This is something else.

#12 Updated by pauldacheez about 7 years ago

If it's still broken on GL/D3D on current dev builds, we'll be happy to reopen this issue. The "something else" was supposedly D3D9, which we all know is a 10-year-old pile of buggy shit, so if there's something more, it'd be nice to know.

#13 Updated by JMC4789 about 7 years ago

  • Status changed from Duplicate to Questionable

This is a D3D9 bug to my knowledge considering the new information. I cannot reproduce it in OpenGL, and D3D11 has the whitebox problem.

#14 Updated by tueidj about 7 years ago

Smells like a scissorbox offset bug from the screenshots.

#15 Updated by delroth about 7 years ago

  • Status changed from Questionable to Won't fix

Closing since #10 is saying this is a D3D9 bug and nobody reproduced it on OGL/D3D11.

Also available in: Atom PDF