Project

General

Profile

Emulator Issues #5135

Metroid Prime - Cheat code problem - update game ini

Added by Nick.Lustig over 8 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have a problem with a special cheatcode in Metroid Prime (1).

The "Have Phazon Beam" cheatcode has no effect,
but all other codes working fine. The point is,
in older revisions the "Have Phazon Beam" code
is working properly.

In the moment I use "3.0-371" and it doesn´t work.
I tried "R4800" and there is no problem, code works fine.

I compared the code from "3.0-371" and "R4800" and they are equal.

So, my question is: Is the cheat code system messed up ?
Or is there any other reason why it doesn't work ?

I have Windows Vista x64 using Dolphin x64.
Metroid Prime: GM8E01 \ USA \ 2002/03/28


Related issues

Has duplicate Emulator - Emulator Issues #6029: Metroid Prime-Phazon beam cheat does not workDuplicate

Is duplicate of Emulator - Emulator Issues #7743: Various Action Replay Codes and Gecko Codes don't workAccepted

History

#1 Updated by DimitriPilot3 over 8 years ago

Did you make sure, in your 3.0-371 installation, to tick the "Enable Cheats" option in the Dolphin Configuration window (under Idle Skipping and Dual Core)? I don't think this option is enabled by default.

(Is the "Have Phazon Beam" code similar to the "Can use Phazon Beam anywhere" codes found on ARCentral?)

#2 Updated by Nick.Lustig over 8 years ago

How shall "all other codes working fine" if cheats are disabled ???
How shall "in older revisions the 'Have Phazon Beam' code
is working properly" if cheats are disabled ???
Also I clearly said that it´s only this ONE special code.
I mean if you read my issue correctly you should
see that your questionis is superfluous -_-

"Have Phazon Beam" code similar to the "Can use Phazon Beam anywhere" ?
Shouldn´t matter because as I said the "Have Phazon Beam" code is
working with older revisions but in the newer revs it has no more effect.
So the code itself CAN'T be the problem.

The "Have Phazon Beam":
01165C8D 08000000
70458245 00000080
087A55A9 000000C5
00458245 0000007C
48457D33 00000000
087A55A9 0000003B
00458245 000000FE

This code is equal in older and newer revs...

Anyway, thanks for advice. I'll take a look on ARCentral.

Edit: None of the "Phazon Beam" with "This Code must be on" codes
from ARCentral is working with Dolphin and or my game version.

#3 Updated by ond666 over 8 years ago

I also noticed this problem a couple of days ago myself, and I’ve tried every region version there is, and every thinkable kind of code with phazon beam in it I could find... none of the these work anymore, not since version 3.0 and up (tough, I haven’t tested the absolutely newest version yet)...

What I’m wondering now is, well have some one fixed this yet, as its obviously a dolphin related problem, as the older ones (as previously mentioned by other users here)like 2,0 could use it without any problems, but... as 3.0 is a lot faster on my computer than 2.0 was I’m not going to revert to the older just to be able to use this cheat in 5 to 15 fps slow motion...

So, please for the continued use by fans of metroid and your other wise amazing emulator, like myself, please try to fix this little issue, if you haven’t already, and please reply to this as fast as possible, and... well, please bring good news when you do...

(Also, excuse my bad English and spelling, I am originally Swedish so...)

#4 Updated by skidau over 8 years ago

Please try to identify the revision where this stopped working.

#5 Updated by Billiard26 over 7 years ago

  • Status changed from New to Questionable

The 01165C8D 08000000 line is not part of the code on arcentral.
AR code handling was changed (fixed) some time ago.
I'd guess the correct AR code works.

So, game ini probably has a bad AR code.

#8 Updated by kostamarino over 7 years ago

  • Status changed from Questionable to Fixed

This issue was closed by revision a8d4c78cec87.

#9 Updated by kostamarino over 7 years ago

This issue was closed by revision a8d4c78cec87.

#10 Updated by kostamarino over 7 years ago

  • Status changed from Fixed to New

#11 Updated by kostamarino over 7 years ago

If removing that line doesn't fix it i don't know what is needed...

#12 Updated by skidau over 7 years ago

issue 6029 has been merged into this issue.

#13 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#14 Updated by JMC4789 over 4 years ago

  • Status changed from New to Duplicate

Honestly if a cheatcode doesn't work, we have other issues with more details than this one about Dolphin's incompatibility with certain cheats.

#15 Updated by JosJuice over 4 years ago

Also available in: Atom PDF