Project

General

Profile

Emulator Issues #5146

TV Show King 2 - crash on start up

Added by paavolah over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

TV Show King 2 (game id WTKPGL)

The game crashes on start up with all the latest builds, giving following error message:

Backpatch - no support for operand size 1
Error encountered accessing emulated address 4082000c.
Culprit instruction:
movzx eax, byte ptr ds:[rbx+rcx]
at 0x18652bc

This is a new issue introduced by one of the latest builds. The game is starting up correctly with dolphin 3.0-305, but some revision after that broke it. 3.0-323 is the first one I noticed had this problem, but I still haven't tested the exact revision that causes this bug (its between 3.0-305 and 3.0-323).

The situation is the same with 32-bit and 64-bit builds. I'm using windows 7 64-bit.


Related issues

Is duplicate of Emulator - Emulator Issues #5114: Fluidity wiiware game crash and can't get ingameFixed

History

#1 Updated by paavolah over 9 years ago

When I'm trying to run the TV Show King 2 with 3.0-323 it says the following:
1)"Backpatch - no support for operand size 1..."
2)"Unhandled disasm case in write handler! Please implement or avoid."
3)"Backpatch - failed to disassemble MOV instruction. Error encountered accessing emulated address 0d8bec6d. Culprit instruction: adc dword ptr ds:[rbx+0xd8bec6d], esp at 0x17c63fbf."
4)"Backpatch: Currently only supporting reads. Attempted to write to 0d8bec6d."

So actually some revision between 305 and 323 broke something, that 324 made a little better. The error message I posted to the original issue post is what all the latest builds are giving (from 3.0-324 forward).

#2 Updated by skidau over 9 years ago

  • Status changed from New to Duplicate

Broken by r4c3a799f08f6f3b6a230987c3e0a1e984cf3a565

Also available in: Atom PDF