Project

General

Profile

Emulator Issues #5185

Metroid Prime 2 and others games with black bars after some lags (DX9,DX11 and OPENGL)

Added by burnhellxp over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):

G2ME01 - Metroid Prime 2 Echoes

2) What is the expected output? What do you see instead?
A black bar below screen

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
I dunno,but there some rev like r6505 doesn't has this issue...

4) What steps will reproduce the problem?
1.Load the new/save game
2.Then play until you get some lags (1,4) the black bar below will appear
3.

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)?
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
GTX560ti
2500K
4GB RAM
WIN 7 64
6) Please provide any additional information below.

7) Attachments. IMPORTANT! We have a limited storage quota on
GoogleCode, so please use a 3rd party host for screenshots or any other
files (http://min.us/ for example).


Related issues

Is duplicate of Emulator - Emulator Issues #4336: Metroid Prime Games FIFO Regressions (revs 6554 and 7185)Fixed

History

#1 Updated by burnhellxp over 8 years ago

r7483 x64 (MAMARIO)
r3.0-397-x64 (emucr)
Has the same problem tested with many config.

#3 Updated by Nick.Lustig over 8 years ago

Curios, because on my rig this black border issue is different.
I have this black border in Metroid Prime Echoes with all newer
revisions for such a long time that I can´t remember if it ever
worked without the border... However, I tried "r6505" as
BurnHellXP suggusted and yeah, no black border o_O
The difference to burnhell's explanation of his problem and mine
is that the black border ALWAYS consists from the beginning
of the game (Excluding the game menu... there is no such border!),
so on my system the lags don´t cause the black border... it's always there.
Waiting for fix, so long... I already tried different Resulutions,
different Aspect Ratio's, Render to Main Window, Crop, Widescreen Hack, etc.

Additional information:
I use Windows Vista x64.
I use the OpenGL graphic backend.
Tested 3.0-419 (x64) --> Black border.
Tested r6505 (x64) --> No black border.
Metroid Prime 2 Echoes \G2MP01\ 2004/05/21 \PAL (Europe).

#4 Updated by captgrrr about 8 years ago

What "other games" have this problem? I was able to reproduce this issue in MP2 when testing issue 5448 but would like to see if other games work better on revisions after about 6523 because MP2 gets crash prone. Also do any of you have this problem if you disable duel core? I have not. For others testing this problem its important to delete your shader cache. This problem goes away after a while if you dont(at least for me)

2xOpteron 256, Radeon HD2600XT(512MB agp), 2GB ram, win7prox64

#5 Updated by burnhellxp about 8 years ago

captg...@hotmail.com, the black bar appear even with the shader cache deleted and like you said "other games" are Sonic Adventure 2 Battle PAL and maybe others.

http://forums.dolphin-emulator.com/showthread.php?tid=35&page=12

Like pauldacheez said on issue 5448, when all models or textures that aren't nailed to the floor as part of the map geometry disappear for a split-second, then reappear, the black bar will appear.

After issue 5448 get a fix, the black bar issue will probably be fixed too

#6 Updated by captgrrr about 8 years ago

If you disable dual core does the problem go away for you in MP2 and Sonic? I don't have Sonic to test.

#7 Updated by captgrrr about 8 years ago

Does the black bar in sonic go away if you enable XFB Virtual? Does the screen flicker when you do?

#8 Updated by Autoran1 almost 8 years ago

Yup confirm this stuff

#9 Updated by Autoran1 almost 8 years ago

OGL seems unaffected
DX9 & 11 slill remain issued
Issue doesn't care about scaling it's good, and Virtual XFB seems helpful, but causes flickering

#10 Updated by Autoran1 almost 8 years ago

This issue like the issue 4336, like many other CP/Fifo issues had startd with
r6554 - ra9ca9cfd9bc8
Sometimes this game starts with blackscreen and sound, requires to resize the windo manually or erase game's Shader Cache, harmless but very annoying

#11 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug
  • Category set to gfx

#12 Updated by Autoran1 over 7 years ago

  • Status changed from New to Duplicate

#13 Updated by nigel.harris.uk about 7 years ago

This issue has now been fixed by an unknown revision.
Been playing for over three hours and theirs no black bars or micro stuttering

#14 Updated by OliverAltamira almost 7 years ago

Issue is still present for me.

Tested with rev3.5-1769 on Win8.
Tried using both the Dx11 and OGL backends on default settings, still getting black bars several minutes in.

#15 Updated by OliverAltamira almost 7 years ago

D'oh. Forgot to mention I tested on MP3 NTSC. Since the issue says other games, I'm assuming MP3 was to be included in this issue also.

Also available in: Atom PDF