Project

General

Profile

Emulator Issues #5302

Tales of Symphonia unable to load disc 2

Added by lisakfreer almost 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I finished disc 1 of Tales of Symphonia and when it goes to the screen to change discs, I know that I am supposed to go to File > Change Disc, that much is obvious. But when I try to load the iso for disc 2, the game screen first says "Checking game disc..." And then says "Please insert the Tales of Symphonia Disc 2" No matter how many times I try to load the iso it does the same thing.

I'm playing it on Dolphin 3.0 64bit on a Windows 7 laptop. The disc 1 iso works perfect, but it just won't recognize the second one for some reason?

History

#1 Updated by lpfaint99 almost 8 years ago

  • Status changed from New to Questionable

i don't have a save file at the end of disc 1, but if I load disc 2 first it prompts for disc 1, and I can successfully change it with dolphin 3.0 x64 on win7. TOS NTSC

note that both discs must be the same region for it to be recognized.
Are you able to start with disc 2 and switch to disc 1?
please upload your savefile and link to it here, don't attach it to the issue tracker because we have a limited storage quota

#2 Updated by lisakfreer almost 8 years ago

Ah, the problem was that the second disc was European, while the first was American. I didn't know they had to be the same region. Thank you for your help, it works now!!! :)

#3 Updated by lpfaint99 almost 8 years ago

  • Status changed from Questionable to Invalid

#4 Updated by DimitriPilot3 almost 8 years ago

The game must be checking exactly for the currently inserted disc's game ID (often 6-character-wide, four plus two), starting at offset 0 in main RAM. In nearly all cases the 3rd character differs depending on the region (most commonly: P=PAL, E=NTSC-U, and J=NTSC-J). Even a region mismatch may cause the game to reject an otherwise expected disc.

Also available in: Atom PDF