Project

General

Profile

Emulator Issues #5352

Wii Sports Resort Bowling Controls Improperly

Added by JMC4789 almost 7 years ago. Updated over 1 year ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
Controls
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

--------------------------------------

Wii Sports Resort, RZTE01

Manual bowling in Dolphin is unpredictable compared to playing on the Wii. The biggest problem noticed was speed control.

To reproduce the bug, just go into Wii Bowling Plus on manual mode and try bowling with the natural timing the game explains. If you have a Wii at the ready, compare it to that and see how the game reacts differently. I tested the other games on the disc in both Wii and Dolphin, and this seems to be the only one where it's far, far different. I think the cause may be because of how you're supposed to let go of the B button during the swing. In further testing, Automatic mode in bowling worked just fine, and I was able to end up with similar scores. If I'm right about the source of the issue, it could be affecting more games, but, I can't really see the lag, so I'm just going to keep it to this game for now. Delaying my release of the B button seemed to alleviate the problem, but it's hard to describe the different timing required for this.

In games with a meter, such as golf, where I could just hold two Wiimotes in one hand and hold buttons, the readings were identical, and my shots were too. So I don't think it's an issue of accuracy causing this.

I've been using 584 dirty and 589 dirty for all of my major testing, but I've also used older versions playing the game.

I am using multiple PCs, one with Windows 7 64 bit with a 2670 QM processor using a Geforce 560M with 296.10 drivers installed. The other is a Core i5 760 @ 2.8 GH (Overclocked to 3.2 for testing) with a Geforce 470, 286.26 drivers; also running Windows 7 64 bit. Both computers used a Kensington USB Adapter. Both exhibited identical behavior with all video modes on.

There are multiple graphics issues, but they are all reported or at least acknowledged. The game runs full speed during bowling, so that shouldn't cause an issue with the Wii Motion Plus timing.

History

#1 Updated by kostamarino almost 7 years ago

Could you try enabling "alternate wiimote timing" before launching the game and see if it helps or not? Right click the game in the gamelist and select properties, then tick the check box (default is filled) to enable it. Afterwards launch the game.

#2 Updated by JMC4789 almost 7 years ago

That didn't fix it, but I appreciate the help. I can't tell if one is better than the other, but both appear to have the same results.

#3 Updated by Billiard26 about 6 years ago

  • Issue type set to Bug
  • Category set to controls

Possibly related to issue 5751.

#4 Updated by JMC4789 about 6 years ago

I can confirm the issue still exists as of 3.5 - 392

#5 Updated by MayImilae over 5 years ago

  • Status changed from New to Accepted

Tested by jchadwick on 3.5-1702 and confirmed. Accepting.

#6 Updated by MayImilae over 5 years ago

Doesn't happen with the Toshiba stack, on either the -TR hellmote or a normal Wiimote. The toshiba stack also has less laggy pointers and no weird issues of difficulty in picking up attachments and the like.

#7 Updated by mwernerxy over 4 years ago

Well, using normal Windows 8.1 bluetooth stack, I don't have this issue anymore. Also my pointer feels quite snappy. Do others still have this issue?

#8 Updated by JMC4789 over 4 years ago

It's not fixed for me.

#9 Updated by jorrit.linnert almost 4 years ago

Hmm, I am using the Linux 64 build 4.0-5586, using a Cambridge Silicon Radio chipset in my Bluetooth adapter (branded as Sitecom on the outer shell). My black WiiMote (emblazoned with the "MotionPlus inside" logo) registers as a Nintendo RVL-CNT-01 (notice the absence of the "-TR" here), BD-address: D8:6B:F7:F1:10:24
I also have a laggy response using both Bowling and to a lesser extent: Golf parts of Wii Sports (Disc-ID: SP2E01)
Wii Sports resort does not even start properly, because my controller is not recgnised as having MotionPlus capabilties, even after re-syncing the thing several times.

#10 Updated by JMC4789 about 3 years ago

Someone else actually noticed this bug and I'm super excited. Not because it helps or anything, but it proves I'm not crazy. w00t.

#11 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Won't fix

Considering this works on Bluetooth Passthrough, I'm going to assume it's host stack issues and bandwidth problems. As such... wontfixing my first ever issue.

Also available in: Atom PDF