Project

General

Profile

Emulator Issues #5361

Skyward Sword Banding

Added by MayImilae over 7 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Skyward Sword's (SOUE01) banding issue is back. Here is a screenshot from the wiki that demonstrates it clearly.

http://wiki.dolphin-emulator.com/images/1/11/ZeldaSS-Banding.jpg

It used to be that you could use anisotropic filtering to fix it (according to the forums anyway), but now it doesn't work. I did however find a way to make it work, but uh...

EFB to Tex - http://img59.imageshack.us/img59/4061/bandingefbtotex.jpg
EFB to Ram (cache) - http://img444.imageshack.us/img444/598/bandingefbtoramwithcach.jpg
EFB to Ram (no cache) - http://img853.imageshack.us/img853/4355/bandingefbtoramwithoutc.jpg

As you can see, EFB to Ram without the cache does not have the banding on Link. Unfortunately, it breaks the background far worse than the problem it solves. EFB to Texture and EFB to Ram with cache both have the proper background, but banding.

I only recently got the game, so I do not know what revision broke the AF trick. And I have no idea why EFB to Ram without cache corrects it. But this is what I found. Sorry I can't be of more help.

Tested in 3.0-589 x64
Windows 7 x64
Core 2 Duo E6750 @ 3.2ghz
nVidia Geforce GTX 275

History

#1 Updated by NaturalViolence over 7 years ago

That's how it's supposed to look. Making it look smoother was/is an enhancement

#2 Updated by skidau over 7 years ago

Does the video back-end have an effect? With which back-end were those screenshots made with?

#3 Updated by MayImilae over 7 years ago

NV, that is not how it was meant to be. Since my TV tuner sucks, take a look at some screenshots on IGN.

http://wiimedia.ign.com/wii/image/article/120/1200249/the-legend-of-zelda-skyward-sword-20111014100623881.jpg
http://wiimedia.ign.com/wii/image/article/119/1197148/the-legend-of-zelda-skyward-sword-20110928070758391.jpg
http://wiimedia.ign.com/wii/image/article/120/1200249/the-legend-of-zelda-skyward-sword-20111014100609647.jpg

Anyway. The pictures were taken in DX9. And... dammit, I didn't check all the backends. DX9 does it, OpenGL does it, but with DX11, turning on AF fixes it. The pictures were taken on DX9. Can someone change this to "Skyward Sword Banding (OpenGL and DX9)" or something? Since there is a possible solution, is this still an issue? Or is this valid enough to address why DX11 works with it, but OpenGL and DX9 do not?

#4 Updated by skidau over 7 years ago

Does the issue still occur with native resolution, unscaled EFB?

#5 Updated by MayImilae over 7 years ago

Nope, it doesn't. Looks fine. Looks fine with scaled EFB Copies on at native resolution as well. However, with a higher internal res and unscaled EFB Copies? The banding is gone. Here's some comparison shots.

Native Resolution, unscaled EFB - http://img152.imageshack.us/img152/2580/soue018.jpg
3x Resolution, scaled EFB - http://img256.imageshack.us/img256/3632/soue019.jpg
3x Resolution, unscaled EFB - http://img802.imageshack.us/img802/5743/soue0110.jpg

#6 Updated by skidau over 7 years ago

  • Status changed from New to Won't fix

ok, in that case, I am leaning towards this being a side-effect of the upscaled EFB and not an actual issue. Sorry.

#7 Updated by MayImilae over 7 years ago

Huh. If that is the case, I wonder why DX11 (with AF) is unaffected...

#8 Updated by white.phoenix over 6 years ago

enabling "Force Texture Filtering" fixes the banding bug in DX9.

http://screencloud.net/v/fBu without "force texture filtering"
http://screencloud.net/v/EX5L with "force texture filtering"

#9 Updated by scientificraver over 6 years ago

But all textures look extremely blurry with Force Texture filtering enabled, so I prefer to play with banding. Maybe someone else will try to fix this annoying bug. Zelda SS is a AAA game so this bug and the DX9 Map bug should both be fixed, regardless if caused by EFB or not.

#10 Updated by white.phoenix over 6 years ago

Blurry how? I've seen no difference.

#11 Updated by scientificraver over 6 years ago

Really? There is a huge difference in most games, since all textures that aren't meant to be filtered look blurry and washed out if filtering is forced, in Zelda SS this applies to most textures in the game, mostly walls and objects. The only game I know that looks somehow better with Force Texture filtering enabled is NewSMBWii, as 2D elements like the flowers in the background seem to be sharper.

Also available in: Atom PDF