Project

General

Profile

Emulator Issues #5370

More convenient RAM modification / RAM watch

Added by kuwaga almost 8 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

RAM search is already implemented as part of the Cheat Manager.
However, this doesn't include a RAM watch feature that'd allow the tracking of multiple addresses yet, and using AR-Codes is a very unconvenient way of modifying the found addresses ad hoc. Being able to do that would be very useful when hunting for glitches, since LUA support doesn't seem to be implemented yet.

I hope it isn't too much to ask. I realize this feature would be of little use to most people, but it shouldn't be too difficult to add, since a working RAM search has already been implemented.

It could also make it easier to come up with more complicated AR codes.

History

#1 Updated by skidau almost 8 years ago

  • Issue type set to Feature request

#2 Updated by parlane almost 8 years ago

  • Status changed from New to Won't fix

Let's be real guys, we have higher priorities to work on. We won't implement this in the foreseeable future so I will mark as WontFix. Submit us a patch and we can merge it.

#3 Updated by DimitriPilot3 almost 8 years ago

In the meantime, a program like Cheat Engine or MHS (Memory Hacking Software) can be a quite valuable tool in Dolphin hacking if you know what you're dealing with (the pointer to MEM1 or MEM2, the reversed byte ordering that make 16-bit and 32-bit comparative sub-searches rather senseless in MHS, etc.). Especially if you're familiar with hex editing, and/or want to use "scripting" in a way or another.

Be sure to read this thread: http://forums.dolphin-emulator.com/showthread.php?tid=17578

Also available in: Atom PDF