Project

General

Profile

Emulator Issues #5418

Another Code: R. Saves corrupt, can't resume saved game.

Added by r.prelude90 almost 7 years ago. Updated about 2 years ago.

Status:
Questionable
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Another Code: R.
RNOP01

2) After a certain point in the game the save slot picture becomes "glitchy" after saving and if I try loading I can't resume from where I saved and I get a black screen with some on-screen buttons.

4) What steps will reproduce the problem?
1. Play until you leave the reception, after meeting the guy working there and collecting souvenirs (you can do all this in 10 minutes starting a new game)
2. Save (notice the glitchy picture, if you try saving before this point everything works properly)
3. Exit and load

5) I'm experiencing this issue on 3.0-631 64bit

Windows7 64bit, i5 2500k, Radeon HD6870

History

#1 Updated by pauldacheez almost 7 years ago

I'd guess that using EFB to RAM without EFB Scaled Copy would fix the save slot picture, but I'm not sure about the other problem here.

#2 Updated by hatarumoroboshi almost 7 years ago

I think I followed carefully all the steps you mentioned (except that I started from an early save point) and it seems that I can still get perfect saves...but maybe I missed something (I'm on WinXP 32-bit using Dx9 plugin)

#3 Updated by skidau almost 7 years ago

prelude, have you been saving the game on 3.0-631 exclusively? Or was the original save game made with an earlier version of Dolphin? We have heard of Wii save corruption issues but have not been able to reproduce them. For example, I have played a game for more than 40hrs, saving frequently and have not encountered this issue.

#4 Updated by skidau almost 7 years ago

Also, have you been using save states? That may cause save corruption issues too.

#5 Updated by r.prelude90 almost 7 years ago

Yeah, after I got this issue the first time I deleted the entire save folder and created the save from scratch using 3.0-631.

And no, I'm not using save states.

#6 Updated by hatarumoroboshi almost 7 years ago

Ok, I "finally" got a corrupted save after 7 hours of play of Another Code: R...anyway I think it is a random problem or due to certain areas, because noticing that the save picture was somewhat corrupted, I changed room and saved again on another slot so I got a good save.
After that I tried to load the corrupted save and it indeed shows only black background, while the save that I made just after the corrupted one is instead perfectly usable.

#7 Updated by Billiard26 about 6 years ago

  • Issue type set to Bug

Is this issue present in recent revisions?
If so, which revision was tested?

#8 Updated by Dmitri.Parshakov over 4 years ago

Issue is still present. I just lost all my progress.

  1. Another Code - R - A Journey into Lost Memories [RNOP01]

  2. Save icon appears to be normal, but upon loading the game screen is black with no interactable objects, but with in-game interface still present, player can access DAS or map, but essentially trapped.

  3. What steps will reproduce the problem?
    Save corruption is completely random. Happened to me in clocktower.
    1)Play the game until you start clocktower clock and get back toy box
    2)Save, icon will appear normally
    3)Load the save file

  4. Dolphin 4.0-2109
    Win7 x64.
    Intel I7-3610qm Geforce GTX660M

#9 Updated by JMC4789 over 4 years ago

This sounds like it could possibly be a game issue. Has anyone tested this on Wii? How rare is it?

#10 Updated by BloodyLunar.Dial over 4 years ago

Same issue present here, corrupt save file, possibly lost all my progress.

1.- Another Code R - A Journey into Lost Memories [RNOJ01]

2.- Save icon appears normal when saving, but when loading it, the game screen appears totally black, in-game interface present, entering to all menus possible BUT the map one.

4.- What steps will reproduce the problem?
Normal saving can corrupt the save data, happened to me just after clearing Chapter 2 {Richard's Campsite}.
- Played game until finishing the chapter.
- Saved normally {Icon appeared to be normal}, then left the game, closed the emulator and shutdowned PC.
- Resuming the game, save icon appeared glitchy, then load save file.

5.- Windows 7 32bit, Pentium Dual Core 2600k, Mobile IntelĀ® 4 Series Express Chipset Family.
Dolphin 3.5-367 32 bit ver.

#11 Updated by pauldacheez over 4 years ago

3.5-367, which is a few thousand versions old
32-bit OS that can't run the last few thousand versions of Dolphin
worthless GPU that can't run the last few thousand versions of Dolphin

Not that it's actually relevant to the issue, but, uh, upgrade ALL your things. (Also, to get newer builds of Dolphin, go to https://dolphin-emu.org/, not that ugly site you got 3.5-367 from.)

Anyhoo, I'm gonna try this game out on real console to see if I run into any save corruption issues. I love running into game bugs.

#12 Updated by JMC4789 almost 3 years ago

i've started playing the game and haven't run into this yet.

#13 Updated by JMC4789 about 2 years ago

I played this game for a good while and never reproduced this bug. There are some EFB Copy timing issues in the game so I'm not willing to say this doesn't happen.

#14 Updated by JMC4789 about 2 years ago

  • Status changed from New to Questionable
  • Priority changed from Normal to Low

Also available in: Atom PDF