Project

General

Profile

Emulator Issues #5448

Flickering in Metroid Prime 2

Added by pauldacheez over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The changes made in gx-optimization caused a bug in Metroid Prime 2 in which all models or textures that aren't nailed to the floor as part of the map geometry can disappear for a split-second, then reappear. This only happens once - it's not a constant flickering; it's something that, at 60fps, you can miss if you blink. This happens every few rooms, usually when opening doors.

This only occurs on dual-core, and was caused by the first commit in gx-optimization.

(Dolphin [Hashless] 3.0-689-dirty 64-bit, OS X 10.7.4.)


Related issues

Is duplicate of Emulator - Emulator Issues #4336: Metroid Prime Games FIFO Regressions (revs 6554 and 7185)Fixed

History

#1 Updated by delroth over 8 years ago

  • Status changed from New to Accepted

Can you confirm this is not because of the hashless branch?

#2 Updated by tommyhl2.SS over 8 years ago

I don't understand how someone can make an issue, blame a merged branch while using an experimental not merged branch? That makes no sense to me.

#3 Updated by pauldacheez over 8 years ago

Hashless is just what I happen to be using right now. (Also, the -dirty is because nobody's bothered to fix the lines at the end of BPStructs.cpp for the quite-finicky Clang.)

I'm just late in filing this issue; I first noticed this when using gx-optimization, but I neglected to file an issue until now. Sorry for that confusion...

#4 Updated by captgrrr over 8 years ago

I can confirm it appears in master 682 win 64bit dx9. Easiest way for me to get it to show is to clear the shader cache folder. The first actors(anything that moves) you see including your hud will strobe on and off a few times whenever you go into a new room. After playing for a while without clearing the shader cache this problem seems to go away for me. It was mentioned in the forums that issue 5185 also shows up from having a fresh shader cache and in DC mode and it looks like its been around a lot longer(svn 6xxx according to the forums) Are we sure this is the earliest build it shows up in? I don't have time to test until probably Sunday.

2x Opteron 256, radeon HD 2600xt 512MB(agp), 2GB ram, win7prox64

#5 Updated by delroth over 8 years ago

Can you check if this also happens with GL and DX11?

#6 Updated by captgrrr over 8 years ago

Yes looks like all 3 backends dx11 being the pickiest on my hardware.

#7 Updated by pauldacheez over 8 years ago

The earliest I've seen it on OpenGL was with the first revision of gx-optimization, as I've said. I don't remember ever seeing it before that.

#8 Updated by captgrrr over 8 years ago

Just did some testing on 645(rev before gx optimization was merged) bug is still present on my machine in dx9-dx11-ogl. Going to see about trying to find when this started happening.

#9 Updated by captgrrr over 8 years ago

Looks like this has been around for a long time. Somewhere between SVN 6523-6575 as far as I can tell. Testing gets really dodgy around those revs because this game was prone to crashing in DC mode. I think issue 5185 may be related as it shows up the same time. If anyone else wants to do some testing on this issue or 5185 its important to remember to delete the shader cache. I didnt think I had either issue until I did.

#10 Updated by delroth over 8 years ago

  • Status changed from Accepted to Questionable

:/ Seriously? I don't have this game, could someone else confirm that gx-optimization did not introduce this bug?

#11 Updated by pauldacheez over 8 years ago

Goddammit, now that I think about it, I was still on the first Metroid Prime when I started using gx-optimization. My memory is surprisingly shitty when it comes to Dolphin bugs...

Sorry, guys. Change the title.

#12 Updated by delroth over 8 years ago

Can you check whether this is the same bug as issue 4336?

#13 Updated by pauldacheez over 8 years ago

Ah, no, that's completely different - that's a constant, persistent flickering (with the entire screen going black) that only happens with Virtual XFB enabled, while this issue's about single flickers that only occur when rooms are loading, doors are opening, and during the save-station-exiting cutscene that plays when you load a file. And these flickers look completely different - this is having all entities (plus the HUD) disappear for a frame or two.

#14 Updated by delroth over 8 years ago

Behavior may have changed with recent revisions but according to what you say this really seems like the same issue to me. Can you enable logging in Dolphin and check if there is a "FIFO Reset" message when the screen flickers?

#15 Updated by pauldacheez over 8 years ago

No, I've tested - they're completely different issues. I still get the other one when I enable Virtual XFB.

As for the log, I get this message every time one of these flickers occurs:

14:40:693 /Users/Paul/dolphin-emu/Source/Core/Core/Src/HW/EXI_DeviceIPL.cpp:297 N[OSREPORT]: << Dolphin SDK - GX release build: Apr 5 2004 04:14:28 (0x2301) >>

#16 Updated by delroth over 8 years ago

  • Status changed from Questionable to New

Ok, keeping this one open then.

#17 Updated by burnhellxp over 8 years ago

r7483 also has the same "Flickering in Metroid Prime 2" and the "black bars issue" it's not a new issue with recent git, since even r7483 has the same problem

And r6505 doesn't have "Flickering in Metroid Prime 2" and also doesn't have the "black bars"

Also the black bar issue appear together with the Flickering, I mean when the Flickering issue occurs, the black bar appear.

#18 Updated by captgrrr over 8 years ago

Finaly got around to narrowing this down better. SVN 6554 Is the first revision with this problem as far as I can tell. Most of the time the game just crashes but im pretty sure ive spotted this a few times before it does. Its also the first revision of other MP2 issues, issue 4336 and issue 5185. This issue is still present with virtual xfb disabled or enabled. I can NOT reproduce issue 5185 with virtual xfb enabled but obviously noone wants to play while issue 4336 is present. Maybe we can merge these together in a MP2 R6554 related issues page or something?

#19 Updated by delroth over 8 years ago

SVN 6554 == ra9ca9cfd9bc8cf26cca58cb86bbc20066bde94fc btw.

#20 Updated by pauldacheez over 8 years ago

...Huh. I tested Sonic Adventure 2 (NTSC-U), and I don't see any black bar, but I do experience flickering similar to the kind I originally filed this issue with. This game's flickering manifests mostly in moments of high load (e.g. getting hit by one of those explosive meteors in Meteor Herd, or having one explode near you), and during the victory animation/score screen upon finishing a level. (I also see a lot of flickering (and here I mean high-Hz flickering) terrain in places, and mipmapping bugs similar to issue 5461.)

#21 Updated by pauldacheez over 8 years ago

(This is on Hashless 699, by the way. I'll test on master if you guys want me to, but I don't think I'll get different results.)

#22 Updated by Autoran1 about 8 years ago

This issue is not about gx-optimization, or some other branch, it's the Duplicate of issue 4336

#23 Updated by delroth about 8 years ago

This issue: "This only happens once - it's not a constant flickering"

issue 4336: "Major flickering. If I had Epilepsy I wouldn't be typing this right now"

Probably linked, but not the same issue.

#24 Updated by Autoran1 about 8 years ago

issue 4336 preety much the same, game flicks when it preloads, sometimes some parts of geometry flicks, nothing constant here like if it was XFB issue

#25 Updated by Autoran1 almost 8 years ago

As it was reported it's geometry flickering when open doors this issue is duplicate of issue 4336 not an issue 5185 which also has flickering of other nature

#26 Updated by pauldacheez almost 8 years ago

Autoran, I filed this issue, and I say this is a duplicate of issue 5185 because that one's what I was talking about. Some objects disappear for a split-second and you get the black bar.

issue 4336 has a different kind of flickering that happens when you use Virtual XFB. The screen flashes black constantly and there's no black bar (it even gets rid of the black bar if you had it). (This may be hard to notice if you have the game running at full speed with vsync - disable vsync and mess with the frame limit [with "Limit by FPS" checked] to make this more obvious.)

I think you just mixed the two up. issue 4336 is the Virtual XFB constant flickering with no black bar, while this issue and issue 5185 are the occasional flash with the black bar.

#27 Updated by Autoran1 almost 8 years ago

Ok, if you say so, but all these 3 issues are originated from one revision
and issue 4336 is not about constant XFB Flicks, it's about black parts of geometry while gathering shader cache exactly the same stuff you've wrote in the first post

#28 Updated by Billiard26 over 7 years ago

  • Category set to gfx
  • Issue type set to Bug

#29 Updated by Autoran1 over 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF